Power Strings


Time Limit: 3000MS

 

Memory Limit: 65536K

Total Submissions: 33623

 

Accepted: 13966


Description


Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).


Input


Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.


Output


For each s you should print the largest n such that s = a^n for some string a.


Sample Input


abcd aaaa ababab .


Sample Output


1 4 3


Hint


This problem has huge input, use scanf instead of cin to avoid time limit exceed.


Source


​Waterloo local 2002.07.01​


KMP,next表示模式串如果第i位(设str[0]为第0位)与文本串
第j位不匹配则要回到第next[i]位继续与文本串第j位匹配。
则模式串第1位到next[n]与模式串第n-next[n]位到n位是匹配的。
如果n%(n-next[n])==0,则存在重复连续子串,长度为n-next[n]。


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int next[1000002];
char s[1000002];
int len;
int get_next(char *s)
{
int i=0,j=-1;
next[0]=-1;
while(i<len)
{
if(j==-1||s[i]==s[j])
{
i++;
j++;
next[i]=j;
}
else
j=next[j];
}
if(len%(len-next[len])==0)
return len/(len-next[len]);
else
return 1;
}
int main()
{
while(gets(s)!=NULL)
{
if(s[0]=='.')
break;
len=strlen(s);
printf("%d\n",get_next(s));
}
return 0;
}