1075. PAT Judge (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

#include<cstdio>
#include<iostream>
#include<string.h>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;

struct person
{
int ID, score,perfectcount,rank;
//bool iscompile;
person() :perfectcount(0),score(-1){}
bool operator<(person p)
{
if (score != p.score)
return score > p.score;
else if (perfectcount != p.perfectcount)
return perfectcount > p.perfectcount;
else
return ID < p.ID;//看题目要求要看完整,有时候并不是自己的设计思想有误,而是自己的代码反映不了自己的思想
//这一点也很重要
}
};
int main()
{
int N, K, M;
cin >> N >> K >> M;
int a[10010][6];
bool iscompile[10010];//判断提交的数据是否通过编译
for (int i = 0; i < 10010; i++)
{
iscompile[i] = false;
for (int j = 0; j < 6; j++)
{
a[i][j] = -2;//第i号用户的第j道题得分初值赋为-2
}
}
int user_id, problem_id, partial_score_obtained;
vector<int> fullmark;
fullmark.push_back(0);
int score;
for (int i = 1; i <=K; i++)
{
cin >> score;
fullmark.push_back(score);
}//记录满分
for (int i = 0; i < M; i++)
{
cin >> user_id >> problem_id >> partial_score_obtained;
if (partial_score_obtained >=0&&a[user_id][problem_id] < partial_score_obtained)
{
a[user_id][problem_id] = partial_score_obtained; iscompile[user_id] = true;
}//只要有一次得分大于等于0,说明该用户通过编译了
else if (partial_score_obtained == -1&& a[user_id][problem_id] < -1)
{
a[user_id][problem_id] = -1;
}//得分为-1说明没通过编译但是也提交了,也就是说-2是表示没提交,不为-2就表示提交了的
}
int sum = 0;
vector<person> vp;
person p;
for (int i = 1; i <=N; i++)
{
sum = 0;
p.perfectcount = 0;
//p.iscompile = false;
for (int j = 1; j <=K; j++)
{
if (a[i][j] >= 0)//计总分只计大于等于0的分值
{
//p.iscompile = true;
sum += a[i][j];
if (a[i][j] == fullmark[j])
p.perfectcount++;
}
}
p.ID = i;
p.score = sum;
if(p.score>=0&&iscompile[i])//只有通过编译最后才能被排名
vp.push_back(p);
}
sort(vp.begin(), vp.end());
int oldrank = 1;
for (int i = 0; i < vp.size(); i++)
{
if (!i || vp[i].score == vp[i - 1].score)
{
vp[i].rank = oldrank;
}
else
{
vp[i].rank = i+1;
oldrank = i + 1;
}
}//设置oldrank来算这种排名12225而不是12223
for (int i = 0; i < vp.size(); i++)
{
printf("%d %05d %d ", vp[i].rank, vp[i].ID, vp[i].score);
for (int j = 0; j < K; j++)
{
if (a[vp[i].ID][j + 1] >= 0)//这个地方的0分情况(通过了编译)与下面未通过编译的0分要区别对待
{ //全部是0分是可以被排名的但全部没被编译通过是不能被排名的
cout << a[vp[i].ID][j + 1];
}
else if (a[vp[i].ID][j + 1] == -2)//一定要看清楚题目要求,是一次都没提交的才打印出‘-’
//也就是说提交了的(-1)不会被打印‘-’
{
cout << "-";
}
else if (a[vp[i].ID][j + 1] == -1)//提交了的但编译没通过是计零分
cout << 0;
if (j != K - 1)
cout << " ";
else
cout << endl;
}
}
return 0;
}