1039. Course List for Student (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5

4 7

BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1

1 4

ANN0 BOB5 JAY9 LOR6

2 7

ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6

3 1

BOB5

5 9

AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1 ZOE1

ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5

ANN0 3 1 2 5

BOB5 5 1 2 3 4 5

JOE4 1 2

JAY9 4 1 2 4 5

FRA8 3 2 4 5

DON2 2 4 5

AMY7 1 5

KAT3 3 2 4 5

LOR6 4 1 2 4 5

NON9 0

/*
#include<string>
#include<cstdio>
#include<set>
#include<map>
#include<iostream>
using namespace std;

int main()
{
int N, K;
//cin >> N >> K;
scanf("%d %d", &N, &K);
map<string, set<int> > m;
int coursei, Ni; char s[5];
for (int i = 0; i < K; i++)
{
//cin >> coursei >> Ni;
scanf("%d %d", &coursei, &Ni);
for (int j = 0; j < Ni; j++)
{
//cin >> s;
scanf("%s", s);
m[s].insert(coursei);
}
}
for (int i = 0; i < N; i++)
{
//cin >> s;
scanf("%s", s);
//cout << s << " " << m[s].size();
printf("%s %d", s, m[s].size());
if (m[s].size())
{
for (set<int>::iterator it = m[s].begin(); it != m[s].end(); it++)
{
//cout << " " << *(it);
printf(" %d", *(it));
}
}
//cout << endl;
printf("\n");
}
return 0;
}
用map最后一个测试点过不了,会超时.顺便提一下char数组赋值给string时会被自动包装*/
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;

const int N = 40010;//总人数
const int M = 26 * 26 * 26*10+ 1;//由姓名散列成的数字上界
vector<int> selectCourse[M];//每个学生选择的课程编号

int getID(char name[])//hash函数,将字符串name转换成数字
{
int id = 0;
for (int i = 0; i < 3; i++)
{
id = id * 26 + (name[i] - 'A');
}
id = id * 10 + (name[3] - '0');
return id;

}
int main()
{
char name[5];
int n, k;
scanf("%d%d", &n, &k);//人数及课程数
for (int i = 0; i < k; i++)//对每门课程
{
int course, x;
scanf("%d%d", &course, &x);//输入课程编号与选课人数
for (int j = 0; j < x; j++)
{
scanf("%s", name);
int id = getID(name);//将名字散列为一个整数作为编号
selectCourse[id].push_back(course);
}
}
for (int i = 0; i < n; i++)//n个查询
{
scanf("%s", name);
int id = getID(name);//获得学生编号
sort(selectCourse[id].begin(), selectCourse[id].end());//从小到大排序
printf("%s %d", name, selectCourse[id].size());//姓名、选课数
for (int j = 0; j < selectCourse[id].size(); j++)
{
printf(" %d", selectCourse[id][j]);//选课编号
}
printf("\n");
}
return 0;
}