题目链接:​​点击打开链接​

Largest prime factor

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11161    Accepted Submission(s): 3945



Problem Description

Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.

 


Input

Each line will contain one integer n(0 < n < 1000000).

 


Output

Output the LPF(n).

 


Sample Input

1

2

3

4

5

 


Sample Output

0

1

2

1

3


大意:求 n 的最大的素数因子在素数集合中所处的位置

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int n;
int shu[1000010]={0};
int main()
{
int num=1;
for(int i=2;i<1000010;i++)
{
if(shu[i]==0)
{
shu[i]=num; // 素数 i 的位置
for(int j=i*2;j<1000010;j+=i)
shu[j]=num; // 数 j 暂时最大素数因子的位置
num++;
}
}
while(~scanf("%d",&n))
{
printf("%d\n",shu[n]);
}
return 0;
}