题目链接:


Labeling Balls


Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 14034

 

Accepted: 4075


Description


Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled withais lighter than the one labeled withb".

Can you help windy to find a solution?


Input


The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.


Output


For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.


Sample Input


5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2


Sample Output


1 2 3 4
-1
-1
2 1 3 4
1 3 2 4



大意:题意:有T组测试数据,每组测试数据第一行有两个数 n,m。代表有 n 个球,接下来 m 行,每行有两个数 a,b,代表 a 球比 b 球轻,让你从小到大输出球的重量,若是相同重量,按照字典序输出。

思路:这个和以前的拓扑排序略微不同,不是考虑入度为 0 的情况。因为假设 n 为 4,4 < 1.则输出的列是 2,3,4,1,而不是按照以前所说的 4,1,2,3 所以要考虑的是先把最重的放在后面,轻的在前面按照字典序输出就可以了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int maxn = 202;
int edge[maxn][maxn];
int indegree[maxn];
int ans[maxn];
int n,m,tot;
bool topo()
{
priority_queue<int> q;
for(int i=1;i<=n;i++)
{
if(indegree[i] == 0)
q.push(i);
}
for(int i=1;i<=n;i++)
{
if(q.empty()) return 0;
else
{
int tp=q.top();
q.pop();
ans[tp]=tot--;
for(int k=1;k<=n;k++)
{
if(edge[tp][k] && (--indegree[k])==0)
q.push(k);
}
}
}
return 1;
}
int main ()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
memset(edge,0,sizeof(edge));
memset(indegree,0,sizeof(indegree));
tot=n;
for(int i=0;i<m;i++)
{
int u,v;
scanf("%d%d",&u,&v);
if(edge[v][u]==0)
indegree[u]++;
edge[v][u]=1;
}
if(topo())
{
for(int i=1;i<=n;i++)
printf(i==n?"%d\n":"%d ",ans[i]);
}
else
puts("-1");
}
return 0;
}