题目链接:​​点击打开链接​


Palindrome


Time Limit: 3000MS

 

Memory Limit: 65536K

Total Submissions: 60656

 

Accepted: 21130


Description


A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 


Input


Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.


Output


Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.


Sample Input


5 Ab3bd


Sample Output


2




记着这个结论,需要加的字符的个数 = 原来字符串的长度 - 原来字符串和逆字符串的最长公共子序列的长度。因为空间有限所以要用


滚动数组即可。


#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int n;
char str1[5010],str2[5010];
int dp[2][5010];
int main()
{
while(~scanf("%d",&n))
{
scanf("%s",str1);
for(int i=0;i<n;i++)
str2[i]=str1[n-i-1];
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(str1[i-1]==str2[j-1])
dp[i%2][j]=dp[(i-1)%2][j-1]+1;
else
dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
}
}
printf("%d\n",n-dp[n%2][n]);
}
return 0;
}