题目链接:​​点击打开链接​

Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3189    Accepted Submission(s): 1575


Problem Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

 


Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

 


Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

 


Sample Input

2

2

20 25

40

1

8

 


Sample Output

08:00:40 am 08:00:08 am


题意:就是一人卖电影票,有两种卖的方法可以一张一张卖,也可以的两张一块儿卖,求他把所有电影票卖完用的最短时间;

题解:数组 a1 [ i ] 为单独卖一张票的时间,数组 a2 [ i ] 为一次卖两张票的时间;

状态转移方程为: dp [ i ] = min ( dp [ i-1 ] + a1 [ i ],dp [ i-2 ] + a2 [ i -1 ] );也就是第 i 个人买票时可以自己单独买,也可以跟前面的邻近的人一块买;

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int MAX=2222;
int n;
int a1[MAX],a2[MAX],dp[MAX];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
memset(a1,0,sizeof(a1));
memset(a2,0,sizeof(a2));
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",&a1[i]);
for(int i=1;i<=n-1;i++)
scanf("%d",&a2[i]);
dp[1]=a1[1];
for(int i=2;i<=n;i++)
{
dp[i]=min(dp[i-1]+a1[i],dp[i-2]+a2[i-1]);
}
int hh=dp[n]/3600+8;
int mm=dp[n]/60%60;
int ss=dp[n]%60;
if(hh<12)
printf("%02d:%02d:%02d am\n",hh,mm,ss);
else
printf("%02d:%02d:%02d pm\n",hh-12,mm,ss);
}
return 0;
}