1046 划拳(JAVA)
原创
©著作权归作者所有:来自51CTO博客作者小羊不会飞的原创作品,请联系作者获取转载授权,否则将追究法律责任
划拳是古老中国酒文化的一个有趣的组成部分。酒桌上两人划拳的方法为:每人口中喊出一个数字,同时用手比划出一个数字。如果谁比划出的数字正好等于两人喊出的数字之和,谁就赢了,输家罚一杯酒。两人同赢或两人同输则继续下一轮,直到唯一的赢家出现。
下面给出甲、乙两人的划拳记录,请你统计他们最后分别喝了多少杯酒。
输入格式:
输入第一行先给出一个正整数 N(≤100),随后 N 行,每行给出一轮划拳的记录,格式为:
其中喊
是喊出的数字,划
是划出的数字,均为不超过 100 的正整数(两只手一起划)。
输出格式:
在一行中先后输出甲、乙两人喝酒的杯数,其间以一个空格分隔。
输入样例:
5
8 10 9 12
5 10 5 10
3 8 5 12
12 18 1 13
4 16 12 15
输出样例:
代码实现:
import java.io.*;
/**
* @author yx
* @date 2022-07-20 21:34
*/
public class Main {
static PrintWriter out=new PrintWriter(System.out);
static BufferedReader ins=new BufferedReader(new InputStreamReader(System.in));
static StreamTokenizer in=new StreamTokenizer(ins);
public static void main(String[] args) throws IOException {
in.nextToken();
int N=(int) in.nval;
int yi_shu=0;
int jia_shu=0;
for (int i = 0; i < N; i++) {
String[] split=ins.readLine().split(" ");
int jia_han=Integer.parseInt(split[0]);
int jia_chu=Integer.parseInt(split[1]);
int yi_han=Integer.parseInt(split[2]);
int yi_chu=Integer.parseInt(split[3]);
if((jia_chu==jia_han+yi_han&&yi_chu==yi_han+jia_han)||(jia_chu!=jia_han+yi_han&&yi_chu!=yi_han+jia_han)){
continue;
}
if(jia_chu==jia_han+yi_han)yi_shu++;
if(yi_chu==yi_han+jia_han)jia_shu++;
}
System.out.println(jia_shu+" "+yi_shu);
}
}