Phone List


Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16978    Accepted Submission(s): 5713


Problem Description


Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.



Input


The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.




Output


For each test case, output “YES” if the list is consistent, or “NO” otherwise.



Sample Input


2
3
911
97625999
91125426
5
113
12340
123440
12345
98346




Sample Output


NO
YES



Source

​2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(3) ​



Recommend

lcy   |   We have carefully selected several similar problems for

you:  ​​1251​​​ ​​1247​​​ ​​1677​​​ ​​1298​​​ ​​2846​​ 




题解:题意不说了。。。。字典树。




AC代码:


#include<stdio.h>
#include<iostream>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
typedef long long LL;

using namespace std;
struct node
{
bool end;
int a[10];
};

bool x;
int ptr;
node list[100000];

void Init()
{
x=true;
ptr=0;
for(int i=0;i<100000;i++)
{
list[i].end=false;
for(int j=0;j<10;j++)
list[i].a[j]=-1;
}
}

void Insert(char*s)
{
bool z=false;
bool y=false;
int now=0;
int len=strlen(s);
for(int i=0;i<len;i++)
{
if(list[now].a[s[i]-'0']==-1)
{
z=true;
list[now].a[s[i]-'0']=++ptr;
now=ptr;
}
else
{
now=list[now].a[s[i]-'0'];
if(list[now].end) y=true;
}
}
list[now].end=true;
x=(!y)&&z;
}

int main()
{
int t,n;
char s[11];
scanf("%d",&t);
while(t--)
{
Init();
scanf("%d",&n);
while(n--)
{
scanf("%s",&s);
if(x) Insert(s);
}
if(x) puts("YES");
else puts("NO");
}
return 0;
}