Pie


Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u


Submit  ​​Status​​​  ​​​Practice​​​  ​​​POJ 3122​


Description




Pie(贪心)_#define

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 



My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 



What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.


Input


  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.


Output


For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10  −3.


Sample Input


33 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2


Sample Output


25.13273.1416 50.2655




参考代码:

//最大最小值问题 二分
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
double v[10005];
#define esp 1e-6
#define pi acos(-1.0)

int n,f;

double mid_sort(double l,double r)
{
double mid;
while(r-l>esp)
{
int cnt=0;
mid=(l+r)/2;
for(int i=0;i<n;i++)
{
cnt+=(int)v[i]/mid;
}
if(cnt<f)
r=mid;
else
l=mid;
}
return mid;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&f);
f++;
double Ms=0;
for(int i=0;i<n;i++)
{
scanf("%lf",&v[i]);
v[i]*=v[i];
if(Ms<v[i])
Ms=v[i];
}
double k=mid_sort(0.0,Ms);
printf("%.4lf\n",k*pi);
}
}