Strategic Game


Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6586    Accepted Submission(s): 3066


Problem Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?


Your program should find the minimum number of soldiers that Bob has to put for a given tree.


The input file contains several data sets in text format. Each data set represents a tree with the following description:


the number of nodes

the description of each node in the following format

node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier

or

node_identifier:(0)


The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.


For example for the tree: 



HDU 1054:Strategic Game_i++

 



the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:


Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)


Sample Output

1
2


Source

​Southeastern Europe 2000​

Recommend

JGShining   |   We have carefully selected several similar problems for you:   ​​1068​​​  ​​1150​​​  ​​1151​​​  ​​1281​​​  ​​1142​​ 

 


迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
int bb[1510],aa[1510],n;
vector<int> G[1510];
bool find(int k)
{
for(int j = 0; j < (int)G[k].size(); j++)
{
int i = G[k][j];
if(!aa[i])
{
aa[i] = 1;
if(bb[i] == -1 || find(bb[i]))
{
bb[i] = k;
return true;
}
}
}
return false;
}
int main()
{
int a, b, c;
while(~scanf("%d", &n))
{
for(int i = 0; i < 1510; i++)G[i].clear();
for(int i = 0; i < n; i++)
{
scanf("%d:(%d)", &a, &c);
for(int j = 0; j < c; j++)
{
scanf("%d", &b);
G[a].push_back(b);
G[b].push_back(a);
}
}
c = 0;
memset(bb, -1, sizeof(bb));
for(int i = 0; i < n; i++)
{
memset(aa, 0, sizeof(aa));
if(find(i)) c++;
}
printf("%d\n",c>>1);
}
return 0;
}