题干:

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probability P of getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output

For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

Sample Output

Case 1: 2

Case 2: 4

Case 3: 6

Note

For the first case, if he wants to rob bank 1 and 2, then the probability of getting caught is 0.02 + (1 - 0.02) * .03 = 0.0494 which is greater than the given probability (0.04). That's why he has only option, just to rob rank 2.

题目大意:

有n个银行,每个银行有v[i]的钱,和被抓住的概率p[i]。你要按一定顺序去抢,要求你被抓住的概率小于等于P,你最多能获得多少钱。 

解题报告:

首先不难证明,假设你选择了其中某num个银行,那么与选择的银行的顺序无关。证明如下:(假设你选择了第i个和的第j个)

考虑被抓的概率:【LightOJ - 1079】Just another Robbery(概率dp,概率背包)_#define,所以是等效的。

或者考虑不被抓的概率:【LightOJ - 1079】Just another Robbery(概率dp,概率背包)_#define_02,所以是等效的。

设定状态dp[i][j]代表前i个银行,得到了j块钱但是不被抓到最大概率。(其实设置最小概率应该也可以,但是转移的时候不是很好写。)

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 10000 + 5;
double dp[205][MAX],P,p[205];
int n,v[205];
int main()
{
int t,iCase=0;
cin>>t;
while(t--) {
scanf("%lf%d",&P,&n);
int sum = 0;
for(int i = 1; i<=n; i++) scanf("%d%lf",&v[i],&p[i]),sum += v[i];
for(int i = 1; i<=n; i++) {
for(int j = 0; j<=sum; j++) dp[i][j]=0;
}
dp[0][0]=1;
for(int i = 1; i<=n; i++) {
for(int j = 0; j<=sum; j++) {
dp[i][j] = dp[i-1][j];
if(j >= v[i]) dp[i][j] = max(dp[i][j],dp[i-1][j-v[i]]*(1-p[i]));
}
}
int ans = 0 ;
for(int i = 0; i<=sum; i++) {
if(dp[n][i] >= 1-P) ans = i;
}
printf("Case %d: %d\n",++iCase,ans);
}


return 0 ;
}