题干:

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized. 

InputThe input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element. 


OutputFor each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line. 


Sample Input

3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2Sample Output 6 5 3 1 2 1

解题报告:

    简单排序即可。两次排序

ac代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct Node {
int index;
double satisfaction;

} cloth[10000000+5];
bool cmp(const Node & a, const Node & b) {
if(a.satisfaction!=b.satisfaction) return a.satisfaction > b.satisfaction;
else {
return a.index<b.index;
}
}
bool cmpp(const Node & a, const Node & b) {
return a.index>b.index;
}
int main()
{
int n,m,k;
double tmp;
while(cin>>n>>m>>k) {
//初始化索引值

for(int i = 1; i<=m; i++) {
cloth[i].index=i;
cloth[i].satisfaction=0;
}
//n只起一个 读入个数的作用,并不参与内存的读写。即此处用完了就没用了
for(int i = 1; i<=n; i++) {
for(int j = 1; j<=m; j++) {
scanf("%lf",&tmp);
cloth[j].satisfaction+=tmp;
}
}
sort(cloth+1,cloth+1+m,cmp);
// for(int i = 1; i<=m; i++) {
// printf("%d %f\n",cloth[i].index,cloth[i].satisfaction);
// }
sort(cloth+1,cloth+1+k,cmpp);
// for(int i = 1; i<=m; i++) {
// printf("%d %f\n",cloth[i].index,cloth[i].satisfaction);
// }
for(int i = 1; i<=k; i++) {
printf("%d%c",cloth[i].index,i==k ? '\n' : ' ');
}
}
return 0 ;
}