题目描述

“水仙花数”是指一个三位数,它的各位数字的立方和等于其本身,比如:153=13+53+3^3。
现在要求输出所有在m和n范围内的水仙花数。

输入描述

输入数据有多组,每组占一行,包括两个整数m和n(100<=m<=n<=999)。

输出描述

对于每个测试实例,要求输出所有在给定范围内的水仙花数,就是说,输出的水仙花数必须大于等于m,并且小于等于n,如果有多个,则要求从小到大排列在一行内输出,之间用一个空格隔开;
如果给定的范围内不存在水仙花数,则输出no;
每个测试实例的输出占一行。

输入样例

100 120
300 380

输出样例

no
370 371

程序代码

import java.util.*;

public class Main {

public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);

while (scanner.hasNextInt()) {
int begin = scanner.nextInt();
int end = scanner.nextInt();
boolean flag = false;
int[] array = new int[10];
int count = 0;

for (int i = begin; i <= end; i++) {
int x = i / 100;
int y = (i % 100) / 10;
int z = i % 10;
if (x * x * x + y * y * y + z * z * z == i) {
flag = true;
array[count] = i;
count++;
}
}

if (!flag) {
System.out.println("no");
continue;
}

for (int i = 0; i < count; i++) {
System.out.print(array[i]);
if (i != count - 1) {
System.out.print(" ");
} else {
System.out.println();
}
}

}

}
}