实验拓扑:

VPN的GRE协议配置_路由表

一、配置IP地址

1上的配置:

IOU3#conf t
IOU3(config)#interface ethernet 0/0
IOU3(config-if)#ip address 10.0.12.1 255.255.255.0
IOU3(config-if)#duplex full
IOU3(config-if)#no shutdown
IOU3(config-if)#exit
IOU3(config)#interface ethernet 0/1
IOU3(config-if)#ip address 192.168.1.254 255.255.255.0
IOU3(config-if)#duplex full
IOU3(config-if)#no shutdown
IOU3(config-if)#exit
IOU3(config)#ip route 0.0.0.0 0.0.0.0 10.0.12.2

net上的配置:

IOU5#conf t
IOU5(config)#interface ethernet 0/0
IOU5(config-if)#ip address 10.0.12.2 255.255.255.0
IOU5(config-if)#duplex full
IOU5(config-if)#no shutdown
IOU5(config-if)#exit
IOU5(config)#interface ethernet 0/1
IOU5(config-if)#ip address 10.0.23.2 255.255.255.0
IOU5(config-if)#duplex full
IOU5(config-if)#no shutdown
IOU5(config-if)#exit

2上的配置:

IOU4#conf t
IOU4(config)#interface ethernet 0/0
IOU4(config-if)#ip address 10.0.23.3 255.255.255.0
IOU4(config-if)#duplex full
IOU4(config-if)#no shutdown
IOU4(config-if)#exit
IOU4(config)#interface ethernet 0/1
IOU4(config-if)#ip address 192.168.2.254 255.255.255.0
IOU4(config-if)#duplex full
IOU4(config-if)#no shutdown
IOU4(config-if)#exit
IOU4(config)#ip route 0.0.0.0 0.0.0.0 10.0.23.2
IOU4(config)#exit

PC1上的配置:

IOU1#conf t
IOU1(config)#interface ethernet 0/0
IOU1(config-if)#ip address 192.168.1.1 255.255.255.0
IOU1(config-if)#duplex full
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.254

PC2上的配置:

IOU2#conf t
IOU2(config)#interface ethernet 0/0
IOU2(config-if)#ip address 192.168.2.1 255.255.255.0
IOU2(config-if)#duplex full
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.254

二、配置tunnel接口

1上的配置:

IOU3(config)#interface tunnel 0
IOU3(config-if)#tunnel source ethernet 0/0
IOU3(config-if)#tunnel destination 10.0.23.3
IOU3(config-if)#tunnel mode gre ip
IOU3(config-if)#ip address 192.168.13.1 255.255.255.0
IOU3(config-if)#tunnel key 123456
IOU3(config-if)#exit

2上的配置:

IOU4(config)#interface tunnel 0
IOU4(config-if)#tunnel source ethernet 0/0
IOU4(config-if)#tunnel destination 10.0.12.1
IOU4(config-if)#tunnel mode gre ip
IOU4(config-if)#ip address 192.168.13.2 255.255.255.0
IOU4(config-if)#tunnel key 123456
IOU4(config-if)#exit


配置OSPF宣告路由

1上的配置:

IOU3(config)#router ospf 1
IOU3(config-router)#network 192.168.1.0 0.0.0.255 area 0
IOU3(config-router)#network 192.168.13.0 0.0.0.255 area 0
IOU3(config-router)#exit

2上的配置:

IOU4(config)#router ospf 1
IOU4(config-router)#network 192.168.2.0 0.0.0.255 area 0
IOU4(config-router)#network 192.168.13.0 0.0.0.255 area 0
IOU4(config-router)#exit


使用show ip route 查看路由表

VPN的GRE协议配置_ip地址_02


使用ping命令测试全网互通

VPN的GRE协议配置_路由表_03