一、实验目的

1、理解配置静态NAT的方法

2、理解配置静态端口映射的方法

3、理解配置动态NAT的方法

4、理解配置PAT的方法

需求:

1、服务器ser01使用静态nat发布服务----外部全局地址为100.0.0.10

2、服务器ser02是一台web服务,仅需要发布http服务器外网全局地址为100.0.0.11

3、vlan30使用动态NAT连接外网,外网IP(100.0.0.21~100.0.0.30)

4、vlan40与vlan50使用pat方式连接外网,外部全局地址为100.0.0.12

二、实验拓扑

NAT 网络地址转换_外网

三、实验步骤

3.网络设备的基础配置

3.交换机IOU9的基础配置

IOU9(config)#vlan 10,20,30,40,50
IOU9(config-vlan)#exit
IOU9(config)#interface vlan 10
IOU9(config-if)#ip address 10
IOU9(config-if)#ip address 10.0.10.254 255.255.255.0
IOU9(config-if)#no shutdown
IOU9(config-if)#exit
IOU9(config)#interface vlan 20
IOU9(config-if)#ip address 10.0.20.254 255.255.255.0
IOU9(config-if)#exit
IOU9(config)#interface vlan 30
IOU9(config-if)#ip address 10.0.30.254 255.255.255.0
IOU9(config-if)#no shutdown
IOU9(config-if)#exit
IOU9(config)#interface vlan 40
IOU9(config-if)#ip address 10.0.40.254 255.255.255.0
IOU9(config-if)#no shutdown
IOU9(config-if)#exit
IOU9(config)#interface vlan 50
IOU9(config-if)#ip address 10.0.50.254 255.255.255.0
IOU9(config-if)#no shutdown
IOU9(config-if)#exit
IOU9(config)#interface ethernet 2/3
IOU9(config-if)#switchport mode access
IOU9(config-if)#switchport access vlan 10
IOU9(config-if)#exit
IOU9(config)#interface ethernet 3/0
IOU9(config-if)#switchport mode access
IOU9(config-if)#switchport access vlan 20
IOU9(config-if)#exit
IOU9(config)#interface ethernet 3/1
IOU9(config-if)#switchport mode access
IOU9(config-if)#switchport access vlan 30
IOU9(config-if)#exit
IOU9(config)#interface ethernet 3/2
IOU9(config-if)#switchport mode access
IOU9(config-if)#switchport access vlan 40
IOU9(config-if)#exit
IOU9(config)#interface ethernet 3/3
IOU9(config-if)#switchport mode access
IOU9(config-if)#switchport access vlan 50
IOU9(config-if)#exit
IOU9(config)#interface ethernet 0/0
IOU9(config-if)#no switchport
IOU9(config-if)#ip address 172.16.1.1 255.255.255.0
IOU9(config-if)#no shutdown
IOU9(config-if)#exit
IOU9(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.2

查看IP地址:show ip interface brief

NAT 网络地址转换_ide_02

查看vlan配置结果:show vlan

NAT 网络地址转换_外网_03

4. 路由器IOU1的基础配置

IOU1(config)#interface ethernet 0/0
IOU1(config-if)#duplex full
IOU1(config-if)#ip address 10.0.12.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface ethernet 0/1
IOU1(config-if)#ip address 100.0.0.1 255.255.255.0
IOU1(config-if)#duplex full
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#ip route 0.0.0.0 0.0.0.0 100.0.0.2
IOU1(config)#ip route 10.0.10.0 255.255.255.0 10.0.12.1
IOU1(config)#ip route 10.0.20.0 255.255.255.0 10.0.12.1
IOU1(config)#ip route 10.0.30.0 255.255.255.0 10.0.12.1
IOU1(config)#ip route 10.0.40.0 255.255.255.0 10.0.12.1
IOU1(config)#ip route 10.0.50.0 255.255.255.0 10.0.12.1

5.路由器IOU2只需要给两个接口配置IP地址即可

IOU2(config)#interface ethernet 0/1
IOU2(config-if)#ip address 100.0.0.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface ethernet 0/0
IOU2(config-if)#ip address 101.0.0.254 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#ex

4、配置NAT实现需求

配置静态NAT发布Ser01

IOU1(config)#ip nat inside source static 192.168.10.1 100.0.0.10

配置端口映射发布Ser02的web服务

IOU1(config)#ip nat inside source static tcp 192.168.20.1 80 100.0.0.11 80

配置动态NAT实现vlan30上网需求

IOU1(config)#ip nat pool pat 100.0.0.12 100.0.0.12 netmask 255.255.255.252
IOU1(config)#access-list 2 permit 192.168.40.0 0.0.0.255
IOU1(config)#access-list 2 permit 192.168.50.0 0.0.0.255
IOU1(config)#ip nat inside source list 2 pool pat overload

在内部和外部接口上启用NAT

IOU1(config)#interface ethernet 0/0
IOU1(config-if)#ip nat inside
IOU1(config-if)#exit
IOU1(config)#interface ethernet 0/1
IOU1(config-if)#ip nat outside
IOU1(config-if)#exit

5.最后结果

NAT 网络地址转换_外网_04