OSPF+RIP+路由重分发+NAT实例_重分发

拓扑网络规划如

IOU1

e0/0 192.168.13.1 /24

e0/1 192.168.12.1 /24

e0/2 10.0.0.1 /24

loo0 1.1.1.1 /32

IOU2

e0/0 192.168.12.2 /24

e0/1 192.168.25.2 /24

loo0 2.2.2.2 /32


IOU3

e0/0 192.168.13.3 /24

e0/1 192.168.34.3 /24

loo0 3.3.3.3 /32


IOU4

e0/0 192.168.34.4 /24

loo0 4.4.4.4 /32



IOU5

e0/0 192.168.25.5 /24

loo0 5.5.5.5 /32



IOU6

e0/0 10.0.0.2 /24

loo0 6.6.6.6



IOU1配置IP地址

IOU1(config)#interface ethernet 0/0
IOU1(config-if)#ip address 192.168.13.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface ethernet 0/1
IOU1(config-if)#ip address 192.168.12.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface ethernet 0/2
IOU1(config-if)#ip address 10.0.0.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface loopback 0
IOU1(config-if)#ip address 1.1.1.1 255.255.255.255
IOU1(config-if)#exit
IOU1(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.2

IOU2配置IP地址

IOU2(config)#interface ethernet 0/0
IOU2(config-if)#ip address 192.168.12.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface ethernet 0/1
IOU2(config-if)#ip address 192.168.25.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface loopback 0
IOU2(config-if)#ip address 2.2.2.2 255.255.255.255
IOU2(config-if)#ex

IOU3配置IP地址以及静态路由

IOU3(config)#interface ethernet 0/0 
IOU3(config-if)#ip address 192.168.13.3 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#ex
IOU3(config)#interface ethernet 0/1
IOU3(config-if)#ip address 192.168.34.3 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#ex
IOU3(config)#interface loopback 0
IOU3(config-if)#ip address 3.3.3.3 255.255.255.255
IOU3(config-if)#no shutdown
IOU3(config-if)#ex
IOU3(config)#ip route 4.4.4.4 255.255.255.255 192.168.34.4

IOU4配置IP地址以及默认路由

IOU4(config)#interface ethernet 0/0 
IOU4(config-if)#ip address 192.168.34.4 255.255.255.0
IOU4(config-if)#no shutdown
IOU4(config-if)#exit
IOU4(config)#interface loopback 0
IOU4(config-if)#ip address 4.4.4.4 255.255.255.255
IOU4(config-if)#ex
IOU4(config)#ip route 0.0.0.0 0.0.0.0 192.168.34.3

IOU5配置IP地址

IOU5(config)#interface ethernet 0/0
IOU5(config-if)#ip address 192.168.25.5 255.255.255.0
IOU5(config-if)#no shutdown
IOU5(config-if)#ex
IOU5(config)#interface loopback 0
IOU5(config-if)#ip address 5.5.5.5 255.255.255.255
IOU5(config-if)#ex

IOU6配置IP地址

IOU6(config)#interface ethernet 0/0
IOU6(config-if)#ip address 10.0.0.2 255.255.255.0
IOU6(config-if)#no shutdown
IOU6(config-if)#ex
IOU6(config)#interface loopback 0
IOU6(config-if)#ip address 100.10.10.10 255.255.255.255
IOU6(config-if)#ex

IOU1配置OSPF

IOU1(config)#router ospf 1
IOU1(config-router)#network 192.168.13.0 0.0.0.255 area 1
IOU1(config-router)#network 192.168.12.0 0.0.0.255 area 0
IOU1(config-router)#network 1.1.1.1 0.0.0.0 area 0
IOU1(config-router)#exit

IOU2配置OSPF以及RIP,重分发

IOU2(config)#router ospf 1
IOU2(config-router)#network 192.168.12.0 0.0.0.255 area 0
IOU2(config-router)#network 2.2.2.2 0.0.0.0 area 0
IOU2(config-router)#redistribute rip metric 200 subnets metric-type 1
IOU2(config-router)#exit
IOU2(config)#router rip
IOU2(config-router)#version 2
IOU2(config-router)#no auto-summary
IOU2(config-router)#network 192.168.25.0
IOU2(config-router)#redistribute ospf 1 metric 5
IOU2(config-router)#ex

IOU3配置OSPF和重分发宣告给其他路由器

IOU3(config)#router ospf 1              
IOU3(config-router)#router-id 3.3.3.3
IOU3(config-router)#network 192.168.13.0 0.0.0.255 area 1
IOU3(config-router)#network 3.3.3.3 0.0.0.0 area 1
IOU3(config-router)#redistribute static metric 5 metric-type 1
IOU3(config-router)#redistribute connected subnets
IOU3(config-router)#ex

IOU5配置RIP版本为2

IOU5(config)#router rip
IOU5(config-router)#version 2
IOU5(config-router)#no auto-summary
IOU5(config-router)#network 192.168.25.0
IOU5(config-router)#network 5.0.0.0
IOU5(config-router)#ex

IOU1上配置NAT

IOU1(config)#ip nat pool pat 100.0.0.10 10.0.0.10 netmask 255.255.255.0
IOU1(config)#access-list 1 permit 10.0.0.0 0.0.255.255
IOU1(config)#ip nat inside source list 1 interface ethernet 0/2 overload

IOU1配置接口出入

IOU6(config)#interface ethernet 0/0
IOU6(config-if)#ip nat inside
IOU6(config-if)#exit
IOU6(config)#interface ethernet 0/1
IOU6(config-if)#ip nat inside
IOU6(config-if)#exit
IOU6(config)#interface ethernet 0/2
IOU6(config-if)#ip nat outside
IOU6(config-if)#exit

使用show ip route 查看路由表

OSPF+RIP+路由重分发+NAT实例_OSPF路由协议_02

使用ping测试网络连通性

OSPF+RIP+路由重分发+NAT实例_RIP路由协议_03