公司内部网络规划如下:

  1. 根据公司现有各部门主机数量和以后增加主机的情况,为每个部门分配一个C类地址,并且每个部门使用一个VLAN,以便于管理。
  2. 分配一个C类地址作为设备的管理地址。

按照上述规划配置设备,已经实现了网络联通。基于信息安全方面考虑,公司要求如下。

  1. 限定不同部门能访问的服务器。例如,财务部只能访问财务部服务器,生产部只能访问生产部服务器。
  2. 网络管理员可以访问所有服务器
  3. 网络设备只允许网管区IP地址通过telnet登录,并配置设备用户名为chengjie,密码为123.123。
  4. 只有网管才能通过远程桌面、Telnet、SSH等登录方式管理服务器。
  5. 要求所有部门之间不能互通,但都可以和网络管理员互通。
  6. 公司中有几名信息安全员,公司要求信息安全员可以访问服务器,但不能访问Intelnet。
  7. 外网只能访问特点服务器的特定服务

根据要求,网络拓扑如下标准ACL与命名ACL的应用_信息安全

IP地址规划如下

标准ACL与命名ACL的应用_信息安全_02

一、路由器、主机和交换机配置IP地址

  1. IOU1的配置
IOU1(config)#interface ethernet 0/0    
IOU1(config-if)#duplex full
IOU1(config-if)#ip address 10.0.0.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface loopback 0
IOU1(config-if)#ip address 123.0.1.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface loopback 1
IOU1(config-if)#ip address 1.1.1.1 255.255.255.255
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
  1. IOU2的配置
IOU2(config)#vlan 2,3,4,100
IOU2(config-vlan)#exit
IOU2(config)#interface ethernet 0/0
IOU2(config-if)#no switchport
IOU2(config-if)#ip address 10.0.0.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1
IOU2(config)#interface range ethernet 0/1-2
IOU2(config-if-range)#switchport trunk encapsulation dot1q
IOU2(config-if-range)#switchport mode trunk
IOU2(config-if-range)#exit
IOU2(config)#interface vlan 1
IOU2(config-if)#ip address 192.168.0.1 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exi
IOU2(config)#interface vlan 2
IOU2(config-if)#ip address 192.168.2.1 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface vlan 3
IOU2(config-if)#ip address 192.168.3.1 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface vlan 4
IOU2(config-if)#ip address 192.168.4.1 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface vlan 100
IOU2(config-if)#ip address 192.168.100.1 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
  1. IOU3的配置
IOU3(config)#interface ethernet 0/0
IOU3(config-if)#switchport trunk encapsulation dot1q
IOU3(config-if)#switchport mode trunk
IOU3(config-if)#exit
IOU3(config)#vlan 2,3,4,100
IOU3(config-vlan)#exit
IOU3(config)#interface ethernet 0/1
IOU3(config-if)#switchport mode access
IOU3(config-if)#switchport access vlan 2
IOU3(config-if)#exit
IOU3(config)#interface ethernet 0/2
IOU3(config-if)#switchport mode access
IOU3(config-if)#switchport access vlan 3
IOU3(config-if)#exit
IOU3(config)#interface ethernet 0/3
IOU3(config-if)#switchport mode access
IOU3(config-if)#switchport access vlan 4
IOU3(config-if)#exit
IOU3(config)#interface vlan 1
IOU3(config-if)#ip address 192.168.0.2 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#exit
  1. IOU4的配置
IOU4(config)#interface ethernet 0/0
IOU4(config-if)#switchport trunk encapsulation dot1q
IOU4(config-if)#switchport mode trunk
IOU4(config-if)#exit
IOU4(config)#vlan 2,3,4,100
IOU4(config-vlan)#exit
IOU4(config)#interface vlan 1
IOU4(config-if)#ip address 192.168.0.3 255.255.255.0
IOU4(config-if)#no shutdown
IOU4(config-if)#exit
IOU4(config)#interface vlan 100
IOU4(config-if)#exit
IOU4(config)#interface ethernet 0/0
IOU4(config-if)#switchport trunk encapsulation dot1q
IOU4(config-if)#switchport mode trunk
IOU4(config-if)#exit
IOU4(config)#interface ethernet 0/1
IOU4(config-if)#switchport mode access
IOU4(config-if)#switchport access vlan 100
IOU4(config-if)#exit
IOU4(config)#ip default-gateway 192.168.0.1
  1. PC1的配置
IOU5(config)#interface ethernet 0/0
IOU5(config-if)#duplex full
IOU5(config-if)#ip address 192.168.2.2 255.255.255.0
IOU5(config-if)#no shutdown
IOU5(config-if)#exit
  1. PC2的配置
IOU6(config)#interface ethernet 0/0
IOU6(config-if)#duplex full
IOU6(config-if)#ip address 192.168.3.2 255.255.255.0
IOU6(config-if)#no shutdown
IOU6(config-if)#exit
  1. PC3的配置
IOU7(config)#interface ethernet 0/0   
IOU7(config-if)#duplex fu
IOU7(config-if)#ip address 192.168.4.2 255.255.255.0
IOU7(config-if)#no shutdown
IOU7(config-if)#exit
  1. 服务器的配置
IOU8(config)#interface ethernet 0/0
IOU8(config-if)#duplex full
IOU8(config-if)#ip address 192.168.100.2 255.255.255.0
IOU8(config-if)#no shutdown
IOU8(config-if)#exit

全网互通结果如下:

标准ACL与命名ACL的应用_ip地址_03

二、路由器与交换机配置vty,是其可以telnet

  1. 路由器的配置
IOU1(config)#username chengjie password 123.123
IOU1(config)#line vty 0 4
IOU1(config-line)#login local
IOU1(config-line)#transport input all
IOU1(config-line)#exit
  1. 三层交换机的配置
IOU2(config)#username chengjie password 123.123
IOU2(config)#line vty 0 4
IOU2(config-line)#login local
IOU2(config-line)#transport input all
IOU2(config-line)#exit
  1. 二层交换机IOU3的配置
IOU3(config)#username chengjie password 123.123
IOU3(config)#line vty 0 4
IOU3(config-line)#login local
IOU3(config-line)#transport input all
IOU3(config-line)#exit
  1. 二层交换机IOU4的配置
IOU4(config)#username chengjie password 123.123
IOU4(config)#line vty 0 4
IOU4(config-line)#login local
IOU4(config-line)#transport input all
IOU4(config-line)#exit
  1. 服务器的配置
IOU8(config)#username chengjie password 123.123
IOU8(config)#line vty 0 4
IOU8(config-line)#login local
IOU8(config-line)#transport input all
IOU8(config-line)#exit

主机PC1telnet网络设备结果如下

标准ACL与命名ACL的应用_服务器_04

主机PC2和PC3不允许telnet网络设备

标准ACL与命名ACL的应用_ip地址_05

公司部门间不能互相通信,但可以与网络管理员通信

标准ACL与命名ACL的应用_ip地址_06

信息安全员可以访问服务器,但不能访问外网

标准ACL与命名ACL的应用_服务器_07