防火墙部署安全策略和NAT

原理概述:

Easy IP是一种利用出接口的公网IP地址作为NAT转后的地址,同时转换地址和端口的地址转换方式,对于接口IP是动态获取的场景,Easy IP也一样支持

当华为防火墙的公网接口通过拨号方式动态获取公网地址时,如果只想使用这一个公网IP地址进行地址转换,此时不能在NAT地址池中配置固定的地址,因为公网IP地址是动态变化的,此时,可以使用Easy IP方式,即使出接口上获取的公网IP地址发生变化,华为防火墙也会按照新的公网IP地址来进行地址转换

当主机通过Easy IP访问Web Server时,华为防火墙的处理过程如下

华为防火墙收到主机发送的报文后,根据目的IP地址判断报文需要在Trust区域和Untrust区域之间流动,通过安全策略检查后继而查找NAT策略,发现需要对报文进行地址转换

华为防火墙使用与Internet连接的接口的公网IP地址替换报文的源IP地址,同时使用新的端口号替换报文的源端口号,并建立会话表,然后将报文发送至Internet

华为防火墙收到Web Server响应主机的报文后,通过查找会话表匹配到步骤2中建立的表项,将报文的目的地址替换为主机的IP地址,将报文的目的端口号替换为原始的端口号,然后将报文发送至Intranet

此方式下,由于地址转换的同时还进行端口的转换,可以实现多个私网用户共同使用一个公网IP地址上网,华为防火墙根据端口区分不同用户,所以可以支持同时上网的用户数量更多

防火墙(英语:Firewall)技术是通过有机结合各类用于安全管理与筛选的软件和硬件设备,帮助计算机网络于其内、外网之间构建一道相对隔绝的保护屏障,以保护用户资料与信息安全性的一种技术。

防火墙技术的功能主要在于及时发现并处理计算机网络运行时可能存在的安全风险、数据传输等问题,其中处理措施包括隔离与保护,同时可对计算机网络安全当中的各项操作实施记录与检测,以确保计算机网络运行的安全性,保障用户资料与信息的完整性,为用户提供更好、更安全的计算机网络使用体验。

所谓“防火墙”是指一种将内部网和公众访问网(如Internet)分开的方法,它实际上是一种建立在现代通信网络技术和信息安全技术基础上的应用性安全技术,隔离技术。越来越多地应用于专用网络与公用网络的互联环境之中,尤其以接入Internet网络为最甚。

防火墙主要是借助硬件和软件的作用于内部和外部网络的环境间产生一种保护的屏障,从而实现对计算机不安全网络因素的阻断。只有在防火墙同意情况下,用户才能够进入计算机内,如果不同意就会被阻挡于外,防火墙技术的警报功能十分强大,在外部的用户要进入到计算机内时,防火墙就会迅速的发出相应的警报,并提醒用户的行为,并进行自我的判断来决定是否允许外部的用户进入到内部,只要是在网络环境内的用户,这种防火墙都能够进行有效的查询,同时把查到信息朝用户进行显示,然后用户需要按照自身需要对防火墙实施相应设置,对不允许的用户行为进行阻断。通过防火墙还能够对信息数据的流量实施有效查看,并且还能够对数据信息的上传和下载速度进行掌握,便于用户对计算机使用的情况具有良好的控制判断,计算机的内部情况也可以通过这种防火墙进行查看,还具有启动与关闭程序的功能,而计算机系统的内部中具有的日志功能,其实也是防火墙对计算机的内部系统实时安全情况与每日流量情况进行的总结和整理。

防火墙是在两个网络通讯时执行的一种访问控制尺度,能最大限度阻止网络中的黑客访问你的网络。是指设置在不同网络(如可信任的企业内部网和不可信的公共网)或网络安全域之间的一系列部件的组合。它是不同网络或网络安全域之间信息的唯一出入口,能根据企业的安全政策控制(允许、拒绝、监测)出入网络的信息流,且本身具有较强的抗攻击能力。它是提供信息安全服务,实现网络和信息安全的基础设施。在逻辑上,防火墙是一个分离器,一个限制器,也是一个分析器,有效地监控了内部网和Internet之间的任何活动,保证了内部网络的安全。

防火墙对流经它的网络通信进行扫描,这样能够过滤掉一些攻击,以免其在目标计算机上被执行。防火墙还可以关闭不使用的端口。而且它还能禁止特定端口的流出通信,封锁特洛伊木马。最后,它可以禁止来自特殊站点的访问,从而防止来自不明入侵者的所有通信。

网络安全的屏障

一个防火墙(作为阻塞点、控制点)能极大地提高一个内部网络的安全性,并通过过滤不安全的服务而降低风险。由于只有经过精心选择的应用协议才能通过防火墙,所以网络环境变得更安全。如防火墙可以禁止诸如众所周知的不安全的NFS协议进出受保护网络,这样外部的攻击者就不可能利用这些脆弱的协议来攻击内部网络。防火墙同时可以保护网络免受基于路由的攻击,如IP选项中的源路由攻击和ICMP重定向中的重定向路径。防火墙应该可以拒绝所有以上类型攻击的报文并通知防火墙管理员。

强化网络安全策略

通过以防火墙为中心的安全方案配置,能将所有安全软件(如口令、加密、身份认证、审计等)配置在防火墙上。与将网络安全问题分散到各个主机上相比,防火墙的集中安全管理更经济。例如在网络访问时,一次一密口令系统和其它的身份认证系统完全可以不必分散在各个主机上,而集中在防火墙一身上。

监控审计

如果所有的访问都经过防火墙,那么,防火墙就能记录下这些访问并作出日志记录,同时也能提供网络使用情况的统计数据。当发生可疑动作时,防火墙能进行适当的报警,并提供网络是否受到监测和攻击的详细信息。另外,收集一个网络的使用和误用情况也是非常重要的。首先的理由是可以清楚防火墙是否能够抵挡攻击者的探测和攻击,并且清楚防火墙的控制是否充足。而网络使用统计对网络需求分析和威胁分析等而言也是非常重要的。

防止内部信息的外泄

通过利用防火墙对内部网络的划分,可实现内部网重点网段的隔离,从而限制了局部重点或敏感网络安全问题对全局网络造成的影响。再者,隐私是内部网络非常关心的问题,一个内部网络中不引人注意的细节可能包含了有关安全的线索而引起外部攻击者的兴趣,甚至因此而暴漏了内部网络的某些安全漏洞。使用防火墙就可以隐蔽那些透漏内部细节如Finger,DNS等服务。Finger显示了主机的所有用户的注册名、真名,最后登录时间和使用shell类型等。但是Finger显示的信息非常容易被攻击者所获悉。攻击者可以知道一个系统使用的频繁程度,这个系统是否有用户正在连线上网,这个系统是否在被攻击时引起注意等等。防火墙可以同样阻塞有关内部网络中的DNS信息,这样一台主机的域名和IP地址就不会被外界所了解。除了安全作用,防火墙还支持具有Internet服务性的企业内部网络技术体系VPN(虚拟专用网)。

日志记录与事件通知

进出网络的数据都必须经过防火墙,防火墙通过日志对其进行记录,能提供网络使用的详细统计信息。当发生可疑事件时,防火墙更能根据机制进行报警和通知,提供网络是否受到威胁的信息。

实验目的:

实现分支之间互访使用公网IP

实验拓扑:

防火墙基础之安全策略和NAT(Easy IP)_网络安全

基础配置:

FW1:

#
interface GigabitEthernet1/0/0
undo shutdown
ip address 192.168.2.20 255.255.255.0
service-manage http permit
service-manage https permit
service-manage ping permit
service-manage ssh permit
service-manage snmp permit
service-manage telnet permit
#
interface GigabitEthernet1/0/1
undo shutdown
ip address 20.0.0.10 255.255.255.0
service-manage http permit
service-manage https permit
service-manage ping permit
service-manage ssh permit
service-manage snmp permit
service-manage telnet permit

防火墙基础之安全策略和NAT(Easy IP)_网络安全_02

FW2:

#
interface GigabitEthernet1/0/0
undo shutdown
ip address 192.168.3.10 255.255.255.0
service-manage http permit
service-manage https permit
service-manage ping permit
service-manage ssh permit
service-manage snmp permit
service-manage telnet permit
#
interface GigabitEthernet1/0/2
undo shutdown
ip address 30.0.0.20 255.255.255.0
service-manage http permit
service-manage https permit
service-manage ping permit
service-manage ssh permit
service-manage snmp permit
service-manage telnet permit

防火墙基础之安全策略和NAT(Easy IP)_安全策略_03

安全策略:

FW1:

#
firewall zone trust
set priority 85
add interface GigabitEthernet0/0/0
add interface GigabitEthernet1/0/0
#
firewall zone untrust
set priority 5
add interface GigabitEthernet1/0/1
#
security-policy
rule name acl1
source-zone trust
destination-zone untrust
source-address 192.168.1.0 mask 255.255.255.0
action permit
rule name acl2
source-zone untrust
destination-zone trust
destination-address 192.168.1.0 mask 255.255.255.0
service ftp
action permit

防火墙基础之安全策略和NAT(Easy IP)_网络安全_04防火墙基础之安全策略和NAT(Easy IP)_安全策略_05

FW2:

#
firewall zone trust
set priority 85
add interface GigabitEthernet0/0/0
add interface GigabitEthernet1/0/0
#
firewall zone untrust
set priority 5
add interface GigabitEthernet1/0/2
#
security-policy
rule name acl1
source-zone trust
destination-zone untrust
source-address 192.168.4.0 mask 255.255.255.0
action permit
rule name acl2
source-zone untrust
destination-zone trust
destination-address 192.168.4.0 mask 255.255.255.0
service ftp
action permit

防火墙基础之安全策略和NAT(Easy IP)_网络安全_06防火墙基础之安全策略和NAT(Easy IP)_网络安全_07

NAT部署:

FW1:

#
nat-policy
rule name natacl1
source-zone trust
destination-zone untrust
source-address 192.168.1.0 mask 255.255.255.0
action source-nat easy-ip

防火墙基础之安全策略和NAT(Easy IP)_防火墙_08

FW2:

#
nat-policy
rule name natacl1
source-zone trust
destination-zone untrust
source-address 192.168.4.0 mask 255.255.255.0
action source-nat easy-ip

防火墙基础之安全策略和NAT(Easy IP)_安全策略_09

配置默认路由:

FW1:

#
ip route-static 0.0.0.0 0.0.0.0 20.0.0.20
ip route-static 192.168.1.0 255.255.255.0 192.168.2.10

防火墙基础之安全策略和NAT(Easy IP)_防火墙_10

FW2:

#
ip route-static 0.0.0.0 0.0.0.0 30.0.0.10
ip route-static 192.168.4.0 255.255.255.0 192.168.3.20

防火墙基础之安全策略和NAT(Easy IP)_安全策略_11

配置路由器:​

R1:

#
interface GigabitEthernet0/0/1
ip address 192.168.2.10 255.255.255.0
#
interface GigabitEthernet0/0/2
ip address 192.168.1.1 255.255.255.0
#
interface NULL0
#
ip route-static 0.0.0.0 0.0.0.0 192.168.2.20

防火墙基础之安全策略和NAT(Easy IP)_防火墙_12

R2:

#
interface GigabitEthernet0/0/1
ip address 20.0.0.20 255.255.255.0
#
interface GigabitEthernet0/0/2
ip address 30.0.0.10 255.255.255.0
#
interface NULL0
#
ip route-static 20.0.0.0 255.255.255.0 20.0.0.10
ip route-static 30.0.0.0 255.255.255.0 30.0.0.20

防火墙基础之安全策略和NAT(Easy IP)_安全策略_13

R3:

#
interface GigabitEthernet0/0/1
ip address 192.168.3.20 255.255.255.0
#
interface GigabitEthernet0/0/2
ip address 192.168.4.1 255.255.255.0
#
interface NULL0
#
ip route-static 0.0.0.0 0.0.0.0 192.168.3.10

防火墙基础之安全策略和NAT(Easy IP)_网络安全_14

配置完成后,验证实验

防火墙基础之安全策略和NAT(Easy IP)_防火墙_15

防火墙基础之安全策略和NAT(Easy IP)_网络安全_16

FW1:

防火墙基础之安全策略和NAT(Easy IP)_防火墙_17

防火墙基础之安全策略和NAT(Easy IP)_网络安全_18

FW2:

防火墙基础之安全策略和NAT(Easy IP)_网络安全_19

防火墙基础之安全策略和NAT(Easy IP)_防火墙_20

实验结束;

备注:如有错误,请谅解!

此文章为本人学习笔记,仅供参考!如有重复!!!请联系本人