OSPF 监测和调试

原理概述:

为了监测OSPF协议的工作状态,VRP系统提供了一系列的查询命令。熟练使用这些命令,可以全面地了解网络的运行状态。同时,VRP系统还提供了一系列的调试命令,用以详细地了解和调试OSPF的工作过程,并知道工作过程中各种事件的细节和关系,查询命令和调试命令的结合使用,有助于快速查找网络的故障点和故障原因,提高查错排错的效率。

老化时间----------默认情况老化时间以S为单位,最大老化时间3600s(1小时0),为了防止LSA老化,OSPF每隔1800s(15分钟)进行周期更新

Sequence序列号----LSA对应序列号,存在正负值的32bit,取值范围0x80000000-0x7FFFFFFF,每次LSA产生变化+1

通过DD报文进行数据库内容对比,会根据LSA中部分字段判断LSA新旧,用于后续数据库同步​

1、如果收到LSA,老化时间3600s,则立刻老化

2、如果老化时间都不为3600s,则先比较LSA序列号,越大越优

3、如果序列号一致,比较LSA的校验和,取值越大越优

4、如果上述序列号、校验和都一致,则比较老化时间:

A、判断两条LSA的老化时间间隔,如果小于15min,则视为同一条LSA

B、判断两条LSA的老化时间间隔,如果大于15min,则优选老化时间更小的

OSPF报文类型:

1类LSA(描述路由器自身的直连信息。重点描述:链路的网络类型、cost值、接口IP)、2类LSA(在广播域网络中,描述路由器以及网段和掩码信息、无cost字段,由DR产生、只在本区域内泛洪,不允许跨越区域泛洪)、3类LSA(只有ABR才能产生3类LSA、只能在area 0中学习到3类LSA计算区域的路由)、4类LSA(由ABR产生,用来描述ASBR)、5类LSA(由ABSR产生,用来描述OSPF自治系统外的路由信息)、7类LSA(只存在于NSSA(非完全末梢区域)中)。

OSPF网络类型:

  • 点到点网络:即Point-to-point(P2P)型网络,是指该接口通过点到点的方式与一台路由器相连。此类型网络不需要进行OSPF的DR、BDR选举。

当链路层协议是PPP或HDLC时,OSPF缺省认为网络类型是P2P。在此类型的网络中,OSPF以组播方式(224.0.0.5)发送协议报文。

  • 广播型多路访问网络:即Broadcast型网络,网络本身支持广播功能。当链路层协议是Ethernet、FDDI时,OSPF缺省认为网络类型是广播型。此类型网络需要进行OSPF的DR、BDR选举。在该类型的网络中,OSPF通常以组播方式(224.0.0.5和224.0.0.6)发送协议报文。
  • 非广播型多路访问网络:即NBMA(Non-Broadcast Multiple Access)型网络,虽然从一个接口可以到达多个目的节点,但是网络本身不支持广播功能,当链路层协议是帧中继、ATM或X.25时,OSPF缺省认为网络类型是NBMA。此时OSPF的邻居需要管理员手工指定。在该类型的网络中,以单播方式发送协议报文。
  • 点到多点网络:即Point-to-multipoint(P2MP)型网络,是指该接口通过点到多点的网络与多台路由器相连。

P2MP型网络比较特殊,没有一种链路层协议会被缺省地认为是点到多点类型。点到多点必须是由其他网络类型强制更改而来。常用做法是将NBMA改为点到多点的网络。在该类型的网络中,缺省情况下以组播方式(224.0.0.5)发送协议报文,也可以根据用户需要,以单播形式发送协议报文。

OSPF各个状态的含义:

exstart:邻居状态变成此状态后,路由器开始向邻居发送DD报文。master和slave关系是在此状态形成的,初始DD序列号也是在此状态下确定的,在此状态下发送的DD报文不包含链路状态描述。

exchange:在此状态下,路由器与邻居之间相互发送包含链路状态信息摘要的DD报文。

loading:在此状态下,路由器与邻居之间相互发送LSR报文,LSU报文,LSAck报文

      full:lsdb同步过程完成。路由器与邻居之间形成了完全的邻接关系。

实验目的:

掌握监测OSPF工作状态的方法

掌握调试OSPF工作过程的方法

实验拓扑:

 路由基础之OSPF的监测和调试_各个状态

1:基础配置:

R1:

#
interface GigabitEthernet0/0/0
ip address 10.0.12.1 255.255.255.0
ospf authentication-mode hmac-md5 1 plain huawei
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
ip address 10.0.1.1 255.255.255.255
#
ospf 1 router-id 10.0.1.1
area 0.0.0.0
network 10.0.1.1 0.0.0.0
network 10.0.12.1 0.0.0.0

R2:

interface Serial4/0/0
link-protocol ppp
ip address 10.0.23.2 255.255.255.0
ospf authentication-mode hmac-md5 1 plain huawei
#
interface Serial4/0/1
link-protocol ppp
#
interface GigabitEthernet0/0/0
ip address 10.0.12.2 255.255.255.0
ospf authentication-mode hmac-md5 1 plain huawei
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
ip address 10.0.2.2 255.255.255.255
#
ospf 1 router-id 10.0.2.2
area 0.0.0.0
network 10.0.2.2 0.0.0.0
network 10.0.12.2 0.0.0.0
area 0.0.0.1
network 10.0.23.2 0.0.0.0

R3:

interface Serial4/0/0
link-protocol ppp
ip address 10.0.23.3 255.255.255.0
ospf authentication-mode hmac-md5 1 plain huawei
#
interface Serial4/0/1
link-protocol ppp
ip address 10.0.34.3 255.255.255.0
#
interface GigabitEthernet0/0/0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
ip address 10.0.3.3 255.255.255.255
#
ospf 1 router-id 10.0.3.3
asbr-summary 10.0.100.0 255.255.255.252
import-route static
area 0.0.0.1
network 10.0.3.3 0.0.0.0
network 10.0.23.3 0.0.0.0
#
ip route-static 10.0.100.1 255.255.255.255 10.0.34.4
ip route-static 10.0.100.2 255.255.255.255 10.0.34.4
ip route-static 10.0.100.3 255.255.255.255 10.0.34.4

R4:

#
interface Serial4/0/0
link-protocol ppp
ip address 10.0.34.4 255.255.255.0
#
interface Serial4/0/1
link-protocol ppp
#
interface GigabitEthernet0/0/0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
ip address 10.0.4.4 255.255.255.255
#
interface LoopBack1
ip address 10.0.100.1 255.255.255.255
#
interface LoopBack2
ip address 10.0.100.2 255.255.255.255
#
interface LoopBack3
ip address 10.0.100.3 255.255.255.255

2:监测OSPF的基本状态:

完成上述配置后,在R2上查看OSPF邻居的相关信息:

 路由基础之OSPF的监测和调试_详细介绍_02

回显信息表明,R2已经与区域0的R1(10.0.1.1)以及区域1的R3(10.0.3.3)建立了邻接关系,状态为FUll。回显信息中还出现了诸如邻居的接口地址,邻居的DR优先级,邻居在LSDB同步时的主从角色等参数。

在R2上查看邻居的概要信息:

 路由基础之OSPF的监测和调试_报文类型_03

可以看到,回显信息中包含了邻居所在的区域,邻居的连接接口,邻居的Router-ID和邻居关系的当前状态

在R2上查看运行OSPF协议的接口信息

 路由基础之OSPF的监测和调试_报文类型_04

可以看到,回显信息包含了接口的IP地址,接口的类型,接口的开销值,接口的DR优先级等参数

在R2上查看接口的详细信息

 路由基础之OSPF的监测和调试_详细介绍_05

可以看到,回显信息包含了G0/0/0接口所连网段的DR、BDR、MTU、Hello时间间隔等参数

在R2上查看LSDB

 路由基础之OSPF的监测和调试_详细介绍_06

可以看到,R2的LSDB成功接收到了所有的LSA,display ospf lsdb 命令后面可以通过添加关键词asbr、ase 、network、nssa和summary来查看相应类型的LSA的详细信息

在R2上使用命令查看LSDB中的Type-5 LSA的详细信息

 路由基础之OSPF的监测和调试_各个状态_07

可以看到,回显信息包含了Type-5 LSA(AS External LSA)的详细信息

在R2查看OSPF路由表

 路由基础之OSPF的监测和调试_网络类型_08

可以看到,回显信息包含了所有OSPF路由条目的相关信息

3:调试OSPF的工作过程

<R1>terminal debugging

开启debug功能

在R1上

<R1>debugging ospf event

结果发现么有任何消息的输出

这是因为OSPF此时工作在常态,并没有发生变化事件

重启OSPF进程

eset OSPF process

观察OSPF邻居关系的建立过程

 路由基础之OSPF的监测和调试_各个状态_09

可以看到,显示信息反映了R1和R2建立邻居邻接关系每一步过程

在获取所需的调试输出信息后,应尽快关闭所有的调试功能,以减轻设备负担

 路由基础之OSPF的监测和调试_各个状态_10

在R2上查看OSPF协议的Hello数据包

 路由基础之OSPF的监测和调试_各个状态_11

一旦获取了所需的调试输出信息后,应尽快关闭所有的调试功能

 路由基础之OSPF的监测和调试_各个状态_12实验结束;

备注:如有错误,请谅解!

此文章为本人学习笔记,仅供参考!如有重复!!!请联系本人!