我这里使用的eve模拟器,网络拓扑如下:
cisco 3725配置:
配置tunnel接口
interface Tunnel1
no shutdown
ip address 1.1.1.1 255.255.255.0
tunnel source 192.168.1.1
tunnel destination 192.168.1.2
配置互联接口ip地址
interface FastEthernet0/0
no shutdown
ip address 192.168.1.1 255.255.255.0
interface FastEthernet0/1
no shutdown
ip address 172.16.0.1 255.255.255.0
配置到VPC2的静态路由
ip route 172.16.1.0 255.255.255.0 1.1.1.2
查看接口状态
linux配置:
1、设置接口临时ip地址,重启后消失(可根据需要配置成永久)
ifconfig eth0 192.168.1.2 netmask 255.255.255.0
ifconfig eth1 172.16.1.1 netmask 255.255.255.0
2、关闭防火墙
service iptables stop
chkconfig iptables off
3、查看并加载gre模块
modprobe ip_gre
lsmod | grep gre
4、开启ipv4路由转发
echo 1 > /proc/sys/net/ipv4/ip_forward
5、配置隧道
ip tunnel add tunnel0 mode gre remote 192.168.1.1 local 192.168.1.2 ttl 200
ip link set tunnel0 up
配置GRE tunnel接口的隧道标识
ip addr add 1.1.1.2 dev tunnel0 peer 1.1.1.1/24
增加一条到对端的路由
ip route add 172.16.0.0/24 dev tunnel0
在linux测试可以ping通gre隧道对端地址
在VPC1测试可以ping通VPC2
6、设置开机自动启动
vi /etc/init.d/gre.sh
ip tunnel add tunnel0 mode gre remote 192.168.1.1 local 192.168.1.2 ttl 200
ip link set tunnel0 up
ip route add 172.16.0.0/24 dev tunnel0
chmod +x /etc/init.d/gre.sh
echo "/etc/init.d/gre.sh">> /etc/rc.d/rc.local(将该文件加载到开机启动的系统文件中)
到此配置完成