Description

  火星人最近研究了一种操作:求一个字串两个后缀的公共前缀。比方说,有这样一个字符串:madamimadam,

我们将这个字符串的各个字符予以标号:序号: 1 2 3 4 5 6 7 8 9 10 11 字符 m a d a m i m a d a m 现在,

火星人定义了一个函数LCQ(x, y),表示:该字符串中第x个字符开始的字串,与该字符串中第y个字符开始的字串

,两个字串的公共前缀的长度。比方说,LCQ(1, 7) = 5, LCQ(2, 10) = 1, LCQ(4, 7) = 0 在研究LCQ函数的过程

中,火星人发现了这样的一个关联:如果把该字符串的所有后缀排好序,就可以很快地求出LCQ函数的值;同样,

如果求出了LCQ函数的值,也可以很快地将该字符串的后缀排好序。 尽管火星人聪明地找到了求取LCQ函数的快速

算法,但不甘心认输的地球人又给火星人出了个难题:在求取LCQ函数的同时,还可以改变字符串本身。具体地说

,可以更改字符串中某一个字符的值,也可以在字符串中的某一个位置插入一个字符。地球人想考验一下,在如此

复杂的问题中,火星人是否还能够做到很快地求取LCQ函数的值。

Input

  第一行给出初始的字符串。第二行是一个非负整数M,表示操作的个数。接下来的M行,每行描述一个操作。操

作有3种,如下所示

1、询问。语法:Qxy,x,y均为正整数。功能:计算LCQ(x,y)限制:1<=x,y<=当前字符串长度。

2、修改。语法:Rxd,x是正整数,d是字符。功能:将字符串中第x个数修改为字符d。限制:x不超过当前字

符串长度。

3、插入:语法:Ixd,x是非负整数,d是字符。功能:在字符串第x个字符之后插入字符d,如果x=0,则在字

符串开头插入。限制:x不超过当前字符串长度

Output

  对于输入文件中每一个询问操作,你都应该输出对应的答案。一个答案一行。

Sample Input

madamimadam

7

Q 1 7

Q 4 8

Q 10 11

R 3 a

Q 1 7

I 10 a

Q 2 11

Sample Output

5

1

0

2

1

HINT

1、所有字符串自始至终都只有小写字母构成。

2、M<=150,000

3、字符串长度L自始至终都满足L<=100,000

4、询问操作的个数不超过10,000个。

对于第1,2个数据,字符串长度自始至终都不超过1,000

对于第3,4,5个数据,没有插入操作。

解题思路: 用splay维护字符串,然后二分+hash判断

代码如下:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1000010;
const int mod = 9875321;
char s[maxn];
namespace SplayTree{
int siz[maxn], fa[maxn], mi[maxn], val[maxn], h[maxn]; //val代表值,h代表节点所在splaytree的Hash函数
int ch[maxn][2], tot, root;
void newnode(int &rt, int father, int k){
rt = ++tot;
siz[rt] = 1, fa[rt] = father;
val[rt] = h[rt] = k;
}
void pushup(int rt){
int l = ch[rt][0], r = ch[rt][1];
siz[rt] = siz[l] + siz[r] + 1;
h[rt] = h[l] + (1LL)*val[rt]*mi[siz[l]] % mod + (1LL)*h[r]*mi[siz[l] + 1] % mod;
h[rt] %= mod;
}
void rotate(int x){ //旋转,把x转到根节点,kind为1代表右旋,kind为0代表左旋
int y = fa[x], kind = ch[y][1] == x;
ch[y][kind] = ch[x][!kind];
fa[ch[y][kind]] = y;
ch[x][!kind] = y;
fa[x] = fa[y];
fa[y] = x;
ch[fa[x]][ch[fa[x]][1] == y] = x;
pushup(y), pushup(x);
}
void splay(int x, int goal) //伸展操作,把根为r的子树调整为goal
{
while(fa[x] != goal)
{
int y = fa[x], z = fa[y];
if(z == goal) rotate(x);
else if((ch[y][1] == x) == (ch[z][1] == y)) rotate(y), rotate(x);
else rotate(x), rotate(x);
}
if(goal == 0) root = x;
}
void build(int &rt, int l, int r, int father){
if(l > r) return;
int mid = (l + r) / 2;
newnode(rt, father, s[mid] - 'a'); //递归申请新节点
build(ch[rt][0], l, mid - 1, rt);
build(ch[rt][1], mid + 1, r, rt);
pushup(rt);
}
int find(int x, int k){ //查找第k位置在splaytree中的位置
int lsum = siz[ch[x][0]] + 1;
if(lsum == k) return x;
else if(lsum < k) return find(ch[x][1], k - lsum);
else return find(ch[x][0], k);
}
void change(int x, int k){
int y = find(root, x);
splay(y, 0);
val[y] = k;
pushup(y);
}
void insert(int x, int k){
int y = find(root, x);
splay(y, 0);
int z = find(root, x + 1);
splay(z, y);
newnode(ch[z][0], z, k);
pushup(z);
pushup(y);
}
int query(int l, int r){
int x = find(root, l - 1); splay(x, 0);
int y = find(root, r + 1); splay(y, x);
return h[ch[ch[root][1]][0]];
}
}

using namespace SplayTree;

int main(){
scanf("%s", s + 2);
int n = strlen(s + 2), m;
mi[0] = 1;
for(int i = 1; i < maxn; i++) mi[i] = mi[i - 1] * 27 % mod;
build(root, 1, n + 2, 0);
tot = n + 2;
scanf("%d", &m);
char op[5], cmd[5];
while(m--){
scanf("%s", op);
if(op[0] == 'Q'){
int x, y;
scanf("%d%d", &x, &y);
int l = 1, r = min(tot - x, tot - y);
x++;
y++;
while(l < r){
int mid = (l + r) / 2;
if(query(x, x + mid - 1) == query(y, y + mid - 1)) l = mid + 1;
else r = mid;
}
printf("%d\n", l - 1);
}
else if(op[0] == 'R'){
int x;
scanf("%d%s", &x, cmd);
change(++x, cmd[0] - 'a');
}
else{
int x;
scanf("%d%s", &x, cmd);
insert(++x, cmd[0] - 'a');
}
}
return 0;
}