STP:生成树协议和链路聚合


生成树三个步骤:

1、选择根网桥:

网桥是交换机的通用叫法,网桥ID是唯一的,选择跟网桥的方法是,先比较网桥的优先级,它的取值范围是0-65535,缺省值32768,如果网桥的优先级一样,比较网桥的MAC地址,
选取交换机网络ID最小的交换机成为根网桥。

2、根端口:

到根网桥最低的路径成本,直接的网桥ID最小,端口ID最小。
根路径成本:网桥到根网桥的路径上所有链路的成本之和。
路径成本与带宽有关,常用的

链路带宽(Mbps) 路径成本
10 100
100 19
1000 4
10000 2

根网桥上的端口都不是根端口

3、指定端口:

根桥上的端口全是指定端口,在每一个网段上选择一个指定端口,非根桥上的指定端口选择顺序:
(1)根路径成本较低
(2)所在的交换机的网桥ID的值较小
(3)端口ID的值较小

BPDU桥协议数据单元,配置BPDU--用于生成树计算,使用组播发送BPDU,拓扑变更通告用于通告网络拓扑的变化。
BPDU报文字段:其中包含根网桥ID、根路径成本、发送网桥ID、端口ID和计时器等。

选取根桥.jpg


4、STP利用BPDU选择根网桥的过程:

(1)当一台交换机第一次启动时,先假定自己是跟网桥,在BPDU报文中的跟网桥ID字段填入自己的网桥ID,并向外发送。
(2)交换机比较接收的BPDU报文中的根网桥ID与自己的网桥ID的值哪个更小,如果接收到的BPDU中的根网桥ID值小于自己的网桥ID值,则用接收到的根网桥ID替换现有的根网桥ID,并向外转发。
(3)收敛后,如果有一台网桥ID值更小的交换机加入进来,那么,它首先把自己当做一个跟网桥在网络中通告。

STP收敛

1、生成树端口的状态
STP在计算过程中,交换机的每个端口都必须一次经历几种状态。
(1)转发:发送、接收用户数据
(2)学习:构建网桥表
(3)侦听:构建“活动”拓扑
(4)阻塞:只接收BPDU
(5)禁用:强制关闭

2、生成树计时器
STP在交换机相互发送BPDU报文时,尽力形成一个无还路的拓扑。STP利用三种计时方法来确保一个网络正确的收敛。
(1)HELLO时间:网桥发送配置BPDU报文之间的时间间隔。在IEEE802.1q标准规定的默认访问时间为2秒。
(2)转发延迟:一个交换机端口在Listening(侦听)和Learning(学习)状态所花费的时间间隔,默认值各为15s。
(3)最大老化时间:交换机在丢弃BPDU报文之前存储它的最大时间。
从阻塞到侦听(20S)
从侦听到学习(15S)
从学习到转发(15S)


链路聚合


链路聚合,是将多个物理二层链路捆绑为一个逻辑二层链路的技术。#
链路聚合解决什么问题:

  1. 增加链路带宽:多个小带宽链路汇聚为一个大带宽链路,一般采用负荷分担模式:符合分担是基于流来进行的,避免乱序。
  2. 增加链路的可靠性:通过冗余的多个链路,一条物理链路出问题,不影响整个逻辑链路。

链路聚合.png


STP配置和链路聚合配置:

STP拓扑.jpg


SW3 和 SW4 的配置

vlan batch 10 20 30 40
interface Ethernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/3
 port link-type access
 port default vlan 10          SW4 配vlan 30
#
interface Ethernet0/0/4
 port link-type access
 port default vlan 20          SW4 配vlan 40

stp mode mstp
stp region-configuration
 region-name huawei1
 revision-level 1
 instance 1 vlan 10 30
 instance 2 vlan 20 40
 active region-configuration

SW1 和 SW2 配置
vlan batch 10 20 30 40
interface Ethernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/4
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

stp mode mstp
stp region-configuration
 region-name huawei1
 revision-level 1
 instance 1 vlan 10 30
 instance 2 vlan 20 40
 active region-configuration

SW1:
stp instance 1 root primary
stp instance 2 root secondary

SW2:
stp instance 1 root secondary
stp instance 2 root primary

SW3 SW4 查询 结果
dis stp brief 
 MSTID  Port                        Role  STP State     Protection
   0    Ethernet0/0/1               ROOT  FORWARDING      NONE
   0    Ethernet0/0/2               DESI  FORWARDING      NONE
   0    Ethernet0/0/3               DESI  FORWARDING      NONE
   0    Ethernet0/0/4               DESI  FORWARDING      NONE
   1    Ethernet0/0/1               ROOT  FORWARDING      NONE
   1    Ethernet0/0/2               ALTE  DISCARDING      NONE
   1    Ethernet0/0/3               DESI  FORWARDING      NONE
   2    Ethernet0/0/1               ALTE  DISCARDING      NONE
   2    Ethernet0/0/2               ROOT  FORWARDING      NONE
   2    Ethernet0/0/4               DESI  FORWARDING      NONE

lacp priority 1000  
[SW1]int Eth-Trunk 1
[SW1-Eth-Trunk1]bpdu en 
[SW1-Eth-Trunk1]bpdu enable     
[SW1-Eth-Trunk1]mode lacp-static 
[SW1-Eth-Trunk1]q
[SW1]int e0/0/3 
[SW1-Ethernet0/0/3]eth-trunk 1
[SW1-Ethernet0/0/3]int e0/0/5
[SW1-Ethernet0/0/5]eth-trunk 1
[SW1-Ethernet0/0/5]int e0/0/6
[SW1-Ethernet0/0/6]eth-trunk 1
[SW1-Ethernet0/0/6]q    
[SW1]int Eth-Trunk 1    
[SW1-Eth-Trunk1]max active-linknumber 2
[SW1-Eth-Trunk1]q
[SW1]dis ip int Eth-Trunk 1
[SW1]display trunkmembership eth-trunk 1

SW5的配置 :
vlan batch 10 20 30 40 50 100
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 100
interface Vlanif10
 ip address 192.168.10.1 255.255.255.0
#
interface Vlanif20
 ip address 192.168.20.1 255.255.255.0
#
interface Vlanif30
 ip address 192.168.30.1 255.255.255.0
#
interface Vlanif40
 ip address 192.168.40.1 255.255.255.0
#
interface Vlanif100
 ip address 10.0.0.1 255.255.255.0
#
ip route-static 12.0.0.0 255.255.255.0 10.0.0.10
interface GigabitEthernet0/0/0
 ip address 10.0.0.10 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 12.0.0.1 255.255.255.0 
#
ip route-static 0.0.0.0 0.0.0.0 10.0.0.1

R1的配置:
<Huawei>sys
[Huawei]sys R1
[R1]un in en    
[R1]user-interface console 0
[R1-ui-console0]idle-timeout 0 0
[R1-ui-console0]q
[R1]int g0/0/0
[R1-GigabitEthernet0/0/0]ip add 10.0.0.10 24
[R1-GigabitEthernet0/0/0]un sh
Info: Interface GigabitEthernet0/0/0 is not shutdown.
[R1-GigabitEthernet0/0/0]int g0/0/1
[R1-GigabitEthernet0/0/1]ip add 12.0.0.1 24
[R1-GigabitEthernet0/0/1]un sh 
[R1-GigabitEthernet0/0/1]dis th
[V200R003C00]
#
interface GigabitEthernet0/0/1
 ip address 12.0.0.1 255.255.255.0 
#
return
[R1-GigabitEthernet0/0/1]q
[R1]ip route-static 0.0.0.0 0.0.0.0 10.0.0.1
[R1]