1012: [JSOI2008]最大数maxnumber

Time Limit: 3 Sec   Memory Limit: 162 MB
Submit: 10322   Solved: 4517
[ Submit][ Status][ Discuss]

Description

  现在请求你维护一个数列,要求提供以下两种操作:1、 查询操作。语法:Q L 功能:查询当前数列中末尾L
个数中的最大的数,并输出这个数的值。限制:L不超过当前数列的长度。2、 插入操作。语法:A n 功能:将n加
上t,其中t是最近一次查询操作的答案(如果还未执行过查询操作,则t=0),并将所得结果对一个固定的常数D取
模,将所得答案插入到数列的末尾。限制:n是非负整数并且在长整范围内。注意:初始时数列是空的,没有一个
数。

Input

  第一行两个整数,M和D,其中M表示操作的个数(M <= 200,000),D如上文中所述,满足D在longint内。接下来
M行,查询操作或者插入操作。

Output

  对于每一个询问操作,输出一行。该行只有一个数,即序列中最后L个数的最大数。

Sample Input

5 100
A 96
Q 1
A 97
Q 1
Q 2

Sample Output

96
93
96

HINT

  数据如下http://pan.baidu.com/s/1i4JxCH3

Source


开一个数组模仿单调递减栈走一发即可,再开一个数组标记位置,以便查询最大值


#include<math.h>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
#define maxn 200005
int a[maxn],b[maxn];
int main(void)
{
	char c;
	int n,d,num=0,x,top=0,ans=0;
	scanf("%d%d",&n,&d);
	for(int i=1;i<=n;i++)
	{
		scanf(" %c%d",&c,&x);
		if(c=='A')
		{
			x=(x+ans)%d;
			while(top>0 && a[top]<=x)
				top--;
			a[++top]=x;
			b[top]=++num;
		}
		else
		{
			x=num-x+1;
			printf("%d\n",ans=a[lower_bound(b+1,b+top+1,x)-b]);
		}
	}
	return 0;
}