一、内容

 Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.
Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.

Input

The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.

Output

For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.

Sample Input

2
1 2 3 4 1 3 5 7
4 2
1
2
3
4
1 4
4 1
1 2 3 4 1 3 5 7
4 1
1
2
3
10
1 4

Sample Output

Case 1:
The minimum cost between station 1 and station 4 is 3.
The minimum cost between station 4 and station 1 is 3.
Case 2:
Station 1 and station 4 are not attainable.

二、思路

  • 题目给了一个表代表每个路径长度的花费。 然后给出了一些点的坐标,那么我们可以根据这些点的坐标和这个表进行建图,将每个点都相互建立一条边,权值就是路程的花费 。 最后求一次floyd输出答案即可。
  • 由于题目所给的花费较大, 那么必须使用64位整型。

三、代码

#include <cstdio>
#include <cmath>
#include <cstring> 
#include <algorithm>
using namespace std;
typedef long long ll;
const int N = 105;
const ll INF = 1e15;
ll g[N][N];
int  n, m, t, x[5], c[5], d[N], u, v; 
void floyd() {
	for (int k = 1; k <= n; k++) {
		for (int i = 1; i <= n; i++) {
			for (int j = 1; j <= n; j++) {
				g[i][j] = min(g[i][j], g[i][k] + g[k][j]);
			}
		}
	}
}
int abs(int a) {
	return a > 0 ? a : -a; 
}
int main() {
	scanf("%d", &t);
	for (int ci = 1; ci <= t; ci++) {
		for (int i = 1; i <= 4; i++) scanf("%d", x + i);
		for (int i = 1; i <= 4; i++) scanf("%d", c + i);
		scanf("%d%d", &n, &m);
		for (int i = 1; i <= n; i++) scanf("%d", d + i);
		//建图  每2个点都建立一条边
		memset(g, 0x3f, sizeof(g));
		for (int i = 1; i <= n; i++) g[i][i] = 0; 
		for (int i = 1; i <= n; i++) {
			for (int j = i + 1; j <= n; j++) {
				int dis = abs(d[i] - d[j]); //可能是相减负数
				ll w = INF;
				for (int k = 1; k <= 4; k++) {
					if (dis <= x[k]) {
						w = c[k]; //求出这段路径的花费
						break;
					}
				}
				g[i][j] = g[j][i] = min(g[i][j], w);
			}
		}	
		floyd();
		printf("Case %d:\n", ci);
		for (int i = 1; i <= m; i++) {
			scanf("%d%d", &u, &v);
			if (g[u][v] == INF) {
				printf("Station %d and station %d are not attainable.\n", u, v);
			} else {
				printf("The minimum cost between station %d and station %d is %lld.\n", u, v, g[u][v]);
			}
		}
	}
	return 0;
}