一、内容

 Thanks to a certain "green" resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water's surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water. 

Input

The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of '#' represents an oily cell, and a character of '.' represents a pure water cell.

Output

For each case, one line should be produced, formatted exactly as follows: "Case X: M" where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.

Sample Input

1
6
......
.##...
.##...
....#.
....##
......

Sample Output

Case 1: 3

二、思路

  • 可以看做一个地图上#的地方可以放置东西。然后问最多能够放多少1x2的小方格。求一下最大匹配即可。

三、代码

#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int N = 605;
pair<int, int> mat[N][N];
char s[N][N];
int t, n;
int dx[4] = {1, 0, 0, -1};
int dy[4] = {0, 1, -1, 0};
bool vis[N][N];
bool dfs(int x, int y) {
for (int i = 0; i < 4; i++) {
int fx = x + dx[i];
int fy = y + dy[i];
if (fx <= 0 || fy <= 0 || fx > n || fy > n || vis[fx][fy] || s[fx][fy] == '.') continue;
vis[fx][fy] = true;
int u = mat[fx][fy].first, v = mat[fx][fy].second;
if (!u || dfs(u, v)) {
mat[fx][fy] = make_pair(x, y); return true;
}
}
return false;
}
void init() {
for (int i = 1; i <= n; i++) {
for (int j = 1; j <= n; j++) mat[i][j].first = 0, mat[i][j].second = 0;
}
}
int main() {
scanf("%d", &t); int T = 1;
while (t--) {
scanf("%d", &n);
init();
for (int i = 1; i <= n; i++) scanf("%s", s[i] + 1);
int ans = 0;
for (int i = 1; i <= n; i++) {
for (int j = 1; j <= n; j++) {
if (s[i][j] == '.' || ((i + j) & 1)) continue;
memset(vis, false ,sizeof(vis));
if (dfs(i, j)) ans++;
}
}
printf("Case %d: %d\n", T++, ans);
}
return 0;
}