一、内容

Let the Balloon Rise

 Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

二、思路

  • 用一个字符数组进行排序,统计出现次数最多的就行了。

三、代码

import java.util.*;

public class HDU_1004 {
	static int n;
	static String[] rec = new String[1005];
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while (true) {
			n = sc.nextInt();
			if (n == 0) return;
			for (int i = 1; i <= n; i++) {
				rec[i] = sc.next();
			}
			Arrays.sort(rec, 1, n + 1);
			int tem = 1 , cnt = 0, temIndex = 1,index = 1;
			for (int i = 2; i <= n; i++) {
				if (rec[i].equals(rec[i - 1])) {
					tem++;
				} else {
					if (cnt < tem) {
						cnt = tem;
						index = temIndex;
					}
					tem = 1;
					temIndex = i;
				}
			}
			//防止在最后
			if (cnt < tem) {
				cnt = tem;
				index = temIndex;
			}
			System.out.println(rec[index]);
		}
 	}
}