按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input

第一行输入元素个数 n (1 <= n <= 15);

第二行输入 n 个整数,保证在 int 范围内。

Output

第一行输出初始链表元素个数;

第二行输出按照逆位序所建立的初始链表;

第三行输出删除重复元素后的单链表元素个数;

第四行输出删除重复元素后的单链表。

Sample Input

1021 30 14 55 32 63 11 30 55 30

Sample Output

1030 55 30 11 63 32 55 14 30 21730 55 11 63 32 14 21

#include <stdio.h>
#include <stdlib.h>
struct node
{
int data;
struct node *next;
};
struct node *head;
int n;
struct node *creat(int n)
{
struct node *p;
int i;
head= (struct node *)malloc(sizeof(struct node));
head->next=NULL;
for(i=1;i<=n;i++)
{
p=(struct node *)malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next=NULL;
p->next=head->next;
head->next=p;
}
return (head);
}
void print (struct node * head)
{
struct node *p;
p=head->next;
while(p!=NULL)
{
printf("%d",p->data);
if(p->next!=NULL)
{
printf(" ");
}
else
{
printf("\n");
}
p=p->next;
}
}

int del (struct node *head,int n)
{
struct node *q,*z,*x;
q=head->next;
while(q!=NULL)
{
z=q;
x=q->next;
while(x!=NULL)
{
if(q->data==x->data)
{
z->next=x->next;
x=z->next;
n--;
}
else
{
z=z->next;
x=x->next;
}
}
q=q->next;

}
return n;
}
int main()
{
int m;
scanf("%d",&n);
head=creat(n);
printf("%d\n",n);
print(head);
m=del(head,n);
printf("%d\n",m);
print(head);
return 0;
}