Problem Description
输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。
Input
第一行输入整数N;;
第二行依次输入N个整数。
Output
第一行分别输出偶数链表与奇数链表的元素个数;
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。
Sample Input
10
1 3 22 8 15 999 9 44 6 1001
Sample Output
4 6
22 8 44 6
1 3 15 999 9 1001

import java.util.Scanner;
import java.util.ArrayList;
public class Main
{

	public static void main(String[] args) 
	{
	 Scanner reader= new Scanner (System.in);
	 int N =reader.nextInt();
	 ArrayList<Integer> List1 =new ArrayList<Integer>();
	 ArrayList<Integer> List2 =new ArrayList<Integer>();
	 for(int i=0;i<N;i++)
	 {
		int  x=reader.nextInt();
		if(x%2==0)
		{
			List1.add(x);
		}
		else
		{
			List2.add(x);
		}
	 }
	 System.out.println(List1.size()+" "+List2.size());
	 for(int i=0;i<List1.size();i++)
	 {
		 if(i==0)
		 {
			 System.out.print(List1.get(i));
		 }
		 else
		 {
			 System.out.print(" "+List1.get(i)); 
		 }
	 }
	 System.out.println();
	 for(int i=0;i<List2.size();i++)
	 {
		 if(i==0)
		 {
			 System.out.print(List2.get(i));
		 }
		 else
		 {
			 System.out.print(" "+List2.get(i)); 
		 }
	 }
	 System.out.println();
     reader.close();
	}

}