题目链接:​​http://poj.org/problem?id=1789​​​

Time Limit: 2000MS Memory Limit: 65536K

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 


Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 

1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 

Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input


4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0


Sample Output


The highest possible quality is 1/3.


Problem solving report:

Description: 给你一个n和n个长为7的字符串。每个字符串表示一个节点,每个节点向其他所有点都有边,边长为两个节点字符串同一位置不同字符的数量,求边权和。

Problem solving: 这道题考察的是最小生成树问题。由于每两个字符串在数组里是不同位置,所以在数组的序号可以看成两个点,这两个点的权值就是这两个字符串不同字符的数量,然后跑一遍最小生成树就行了。

Accepted Code:

/* 
* @Author: lzyws739307453
* @Language: C++
*/
#include <queue>
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 2005;
const int MAXM = MAXN * MAXN;
const int inf = 0x3f3f3f3f;
bool vis[MAXN];
int mp[MAXN][MAXN], dis[MAXN];
struct edge {
int v, w;
edge() {}
edge(int v, int w) : v(v), w(w) {}
bool operator < (const edge &s) const {
return s.w < w;
}
};
int prim(int s, int n) {
priority_queue <edge> Q;
for (int i = 0; i < n; i++) {
vis[i] = 0;
dis[i] = inf;
}
dis[s] = 0;
Q.push(edge(s, dis[s]));
int ans = 0;
while (!Q.empty()) {
edge u = Q.top();
Q.pop();
if (vis[u.v])
continue;
vis[u.v] = 1;
ans += u.w;
for (int j = 0; j < n; j++) {
if (!vis[j] && dis[j] > mp[u.v][j]) {
dis[j] = mp[u.v][j];
Q.push(edge(j, dis[j]));
}
}
}
return ans;
}
int slove(char sa[], char sb[]) {
int ans = 0;
for (int i = 0; i < 7; i++)
if (sa[i] != sb[i])
ans++;
return ans;
}
int main() {
int n;
char str[MAXN][10];
while (scanf("%d", &n), n) {
for (int i = 0; i < n; i++) {
scanf("%s", str[i]);
for (int j = 0; j < i; j++)
mp[i][j] = mp[j][i] = slove(str[i], str[j]);
}
printf("The highest possible quality is 1/%d.\n", prim(0, n));
}
return 0;
}