题目链接:http://poj.org/problem?id=2478
Time Limit: 1000MS Memory Limit: 65536K

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

Problem solving report:

Description: 给一个数n让求Fn这个集合中有多少个数,Fn是1-n互质的数构成的分数.
Problem solving: 给定1个n,我们可以从1-n遍历,每次看1-i范围内和i互质的数有多少个其实就能构成多少个分数,然后不断求和即答案,而1-i范围内有多少个和i互质的数就是求欧拉函数,打个表求一下前缀和就行了。

Accepted Code:

/* 
 * @Author: lzyws739307453 
 * @Language: C++ 
 */
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 1e6 + 5;
int pha[MAXN];
long long ans[MAXN];
void slove() {
    for (int i = 0; i < MAXN; i++)
        pha[i] = i;
    for (int i = 2; i < MAXN; i++)
        if (!(pha[i] != i))
            for (int j = i; j < MAXN; j += i)
                pha[j] = pha[j] / i * (i - 1);
    ans[1] = 0;
    for (int i = 2; i < MAXN; i++)
        ans[i] = ans[i - 1] + pha[i];
}
int main() {
    slove();
    int n;
    while (scanf("%d", &n), n)
        printf("%lld\n", ans[n]);
    return 0;
}