Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)
Problem Description
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
Output
Sample Input
5 3
1 2
2 3
4 5
5 1
2 5
Sample Output
合并同关系的
然后查找共有多少顶点(i==find(i))
#include<stdio.h>
int par[1200];
int find(int m) {
if(m==par[m])
return m;
else
return par[m]=find(par[m]);
}
void unite(int x,int y) {
x=find(x);
y=find(y);
if(x==y)
return ;
else
par[y]=x;
}
int main() {
int T;
scanf("%d",&T);
while(T--) {
int n,m;
scanf("%d %d",&n,&m);
for(int i=1; i<=n; i++)
par[i]=i;
while(m--) {
int a,b;
scanf("%d %d",&a,&b);
unite(a,b);
}
int res=0;
for(int i=1; i<=n; i++)
if(i==find(i))
res++;
printf("%d\n",res);
}
return 0;
}