Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Solution: 题目的意思很明显给定一个树输出它的叶子节点(从上到下,从左到右输出)。其中给定的这棵树有N个节点(从0开始编号),对于每一个节点还给出它的左右儿子的索引及左右儿子的位置。因此,我们可以采用顺序存储结构来存储这颗二叉树,因为树是以顺序索引的格式给定的,因此我们需要确定这个二叉树的根节点,其中根节点最明显的特征就是他不是任何节点的儿子,因此我们需要采用一个标记数组来确定其根节点。其中输出叶子节点可以采用层次遍历的方法进行输出。其中我们使用 null=−1null=−1来表示该节点不存在。

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6 

Sample Output:

4 1 5
Code
#include<bits/stdc++.h>
using namespace std;
typedef int Tree;
#define Null -1
struct TreeNode {
	int data;
	Tree left;
	Tree right;
};

int buildTree(vector<TreeNode>&tree,int N) {
	Tree Root = -1;
	char cl, cr;
	vector<int>book(N, 0);

	for (int i = 0; i < N; ++i) {
		cin >> cl >> cr;
		tree[i].data = i;
		if (cl != '-') {
			tree[i].left = (int)cl - '0';
			book[tree[i].left] = 1;
		}
		else
			tree[i].left = Null;
		if (cr != '-') {
			tree[i].right = (int)cr - '0';
			book[tree[i].right] = 1;
		}
		else
			tree[i].right = Null;
	}
	int i = 0;
	for (; i < N; ++i)
		if (!book[i]) {
			Root = i;
			break;
		}
	return Root;
}

vector<int> findLeaves(const vector<TreeNode>&tree, Tree Root) {
	vector<int> leaves;
	queue<TreeNode> qu;
	TreeNode node;

	if (Root == Null)return {};
	qu.push(tree[Root]);
	while (!qu.empty()) {
		node = qu.front();
		qu.pop();
		//如果该节点左右儿子都不存在则为根节点
		if ((node.left == Null) && node.right == Null)
			leaves.push_back(node.data);
		if (node.left != Null) qu.push(tree[node.left]);
		if (node.right != Null) qu.push(tree[node.right]);
	}
	return leaves;
}

int main() {
	int N;

	Tree Root;
	cin >> N;
	vector<TreeNode>tree(10);
	Root = buildTree(tree, N);

	auto res = findLeaves(tree, Root);
	for (decltype(res.size())i = 0; i != res.size(); ++i)
	{
		cout << res[i];
		//注意:最后一个数字输出后没有空格
		i != res.size() - 1 ? cout << " " : cout << endl;
	}

	return 0;
}

The desire of his soul is the prophecy of his fate
你灵魂的欲望,是你命运的先知。