A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (&lt100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (&ltN) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (&gt0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4
#include<cstdio>
#include<vector>
using namespace std;
const int maxn = 110;
int hashtable[maxn] = {0};
vector<int> node[maxn];

void DFS(int index, int level){
 hashtable[level]++;
    for(int i = 0; i < node[index].size(); i++){
     DFS(node[index][i],level+1);    
    }
}

int main() {
    int n,m,father,child,k;
    scanf("%d%d",&n,&m);
    for(int i = 0 ; i < m; i++){
    scanf("%d%d",&father,&k);
        for(int j = 0; j < k; j++){
          scanf("%d",&child);
            node[father].push_back(child);
        }
    }
    DFS(1,1);
    int maxlevel = -1, maxvalue = 0;
    for(int i = 0; i < maxn; i++){
    if(maxvalue < hashtable[i]){
     maxvalue = hashtable[i];
        maxlevel = i;
    }
    }
    printf("%d %d",maxvalue,maxlevel);
    return 0;
}