RouterOS SCript课程系列
第64课程 RouterOS Script语言
RouterOS script语言是RouterOS内置的,功能强大,语法灵活,脚本经常与命令结合,通过脚本,可以实现自动化操作,提高工作效率等,
RouterOS脚本语言非常的强大,是整个RouterOS的核心,是精通RouterOS的必由之路。
熟悉Script脚本的前提是熟悉RouterOS的CLI命令行操作。我们将利用几节课的时间来进行学习,那现在就开始吧。
8、循环语句:
三种方式:while,for,foreach
do..while与while..do
:do { <commands> } while=( <conditions> ); 执行,直到不满足条件退出
:global a 100;
:do {:put $a;:set a ($a-1)} while= ( $a>0 ) 条件不满足退出
:while ( <conditions> ) do={ <commands> };
:global a 100;
:while ( $a > 0 ) do={:put $a;:set a ($a-1) }; 条件满足,执行循环
:for <var> from=<int> to=<int> step=<int> do={ <commands> }
# 输出10到10之间的偶数,step=2
:for a from=10 to=100 step=2 do={:put $a};
:for ipa from=1 to=100 do={:log warning ("192.168.100.".$ipa)};
:foreach <var> in=<array> do={ <commands> };
:foreach a in={1,2,3,3,4,5,6,7} do={:put $a}
:foreach i in=[/ppp secret find] do={
:local userN [/ppp secret get $i name]
log warning $userN;
}
:foreach i in=[/ppp secret find] do={
:local Ser [/ppp secret get $i service]
log error $Ser;
}
:if(<condition>) do={<commands>} else={<commands>} <expression>
{
:local myBool true;
:if ($myBool = !true) do={ :put "value is false" } else={ :put "value is true" }
}
:log warning ("===============")
:foreach i in=[/ip firewall nat find] do={
:local status [/ip firewall nat get $i disable];
if ( $status ) do={:log warning "enabled"} else={:log error "disabled"}
}
:log warning ("===============")
9 、函数 Function
RouterOS script语言不能直接直接定义函数,但是可以使用:parse命令来解决
从v.6.2开始,增加新语法,定义就更轻松,方便了,甚至可以传递参数,还可以用return返回值
#定义函数并运行
:global aaa "ddddd";
:global myFunc do={:put "hello from function"}
$myFunc
output:
hello from function
#p给函数传递参数
:global myFunc do={:put "arg a=$a"; :put "arg '1'=$1"}
$myFunc a="this is arg a value" "this is arg1 value"
output:
arg a=this is arg a value
arg '1'=this is arg1 value
:global aaa do={:put "a=$a";:put "bb=$2"}
输出:
$aaa a="0009999" "bbbbbbb" "ccce2333"
a=0009999
bb=ccce2333
$aaa "bbbbbbb" a="0009999" "ccce2333"
a=0009999
bb=ccce2333
$aaa a="0009999" "ccce2333" "bb1212bbbbb"
a=0009999
bb=bb1212bbbbb
传递具有特定名称的arg(示例中为“ a”)
没有arg名称的pass值,在这种情况下使用arg“ 1”,“ 2” ..“ n”
再看一个例子:
:global myFunc do={ :return ($a + $b)}
:put [$myFunc a=6 b=2] #传递2个参数a和b
output:
8
课后思考:
写一个脚本,禁用service为ovpn的用户,启用用户名以c开头的用户
并用分别用log warning和log error输出信息
参考答案:
:foreach user in=[/ppp secret find] do={
:local Name [/ppp secret get $user name];
:local Serv [/ppp secret get $user service];
:local status [/ppp secret get $user disabled];
if ( $Serv="ovpn" ) do={/ppp secret dis $user;log warning "OVPN:$Name is disabled";}
if ([:pick $Name 0 1] ="c" && $status =true) do={/ppp secret ena $user;log error "User:$Name is enable"}
}