1837: LT说我不服
Time Limit: 1 Sec Memory Limit: 128 MBDescription
Input
Output
每组样例输出一行答案。
Sample Input
2 10000 9999 5 1 9999 1 9999 1
Sample Output
19999 21989
HINT
范围在int内
这一题可以转化为求最大子串和问题
因为若不改变值,则结果为a1~n的和
若求出每一个数的(x*1888+101)%14507与x的差值
改变某一区间的值,则可以表示为选取一个子串
若想要最终结果最大,很显然要让选取的这个子串和最大
所以dp求解,复杂度O(n)
#include<stdio.h>
int a[100200];
int main() {
int n;
while(scanf("%d",&n)!=EOF) {
int sum=0,res=0,x=0;
for(int i=0; i<n; i++) {
scanf("%d",&a[i]);
sum+=a[i];
if(x>0) {
x+=(a[i]*1888+101)%14507-a[i];
} else
x=(a[i]*1888+101)%14507-a[i];
if(res<x)
res=x;
}
printf("%d\n",sum+res);
}
return 0;
}
题目地址:【郑轻】[1837]LT说我不服