Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input 5 green red blue red red 3 pink orange pink

Sample Output red pink 该题简单来说就是统计字符串出现的次数,然后输出最多出现的那个字符串。在这里我使用一个map,键为string,值为该string出现的次数。最后输出值最大的所对应的那个键。

#include <iostream>
#include <map>
#include <string>
using namespace std;
int main(){
    int n;
    while(cin >> n && n){
        map<string, int> result;
        string temp;
        for(int i = 0; i < n; i++){
            cin >> temp;
            result[temp]++;
        }
        int max = -1;
        for(auto iter = result.begin(); iter != result.end(); iter++){
            if(iter->second > max){
                max = iter->second;
                temp = iter->first;
            }
        }
        cout << temp << endl;
    }
    return 0;
}

https://mp.weixin.qq.com/s/skG8NiGeMeZ3B47YdpiMhg