第4章-9 查询水果价格 (15 分)

一、题目链接

二、题目详情

题目描述

给定四种水果,分别是苹果(apple)、梨(pear)、桔子(orange)、葡萄(grape),单价分别对应为3.00元/公斤、2.50元/公斤、4.10元/公斤、10.20元/公斤。

首先在屏幕上显示以下菜单:

[1] apple
[2] pear
[3] orange
[4] grape
[0] exit

用户可以输入编号1~4查询对应水果的单价。当连续查询次数超过5次时,程序应自动退出查询;不到5次而用户输入0即退出;输入其他编号,显示价格为0。

输入格式

输入在一行中给出用户连续输入的若干个编号。

输出格式

首先在屏幕上显示菜单。然后对应用户的每个输入,在一行中按格式“price = 价格”输出查询结果,其中价格保留两位小数。当用户连续查询次数超过5次、或主动输入0时,程序结束。

样例输入1

3 -1 0 2

样例输出1

[1] apple
[2] pear
[3] orange
[4] grape
[0] exit
price = 4.10
price = 0.00

样例输入2

1 2 3 3 4 4 5 6 7 8

样例输出2

[1] apple
[2] pear
[3] orange
[4] grape
[0] exit
price = 3.00
price = 2.50
price = 4.10
price = 4.10
price = 10.20

三、Python参考解答

'''
Author: Gu Jiakai
Date: 2021-07-14 21:35:12
LastEditTime: 2021-07-14 21:55:31
LastEditors: Gu Jiakai
Description: 
FilePath: \pat\第4章-9 查询水果价格 .py
'''
print('''[1] apple
[2] pear
[3] orange
[4] grape
[0] exit''')
# print('[1] apple')
# print('[2] pear')
# print('[3] orange')
# print('[4] grape')
# print('[0] exit')

lst=input().split()
for i in range(len(lst)):
    if lst[i]=='0' or i >=5:
        exit(0)
    elif lst[i]=='1':
        print('price = 3.00')
    elif lst[i]=='2':
        print('price = 2.50')
    elif lst[i]=='3':
        print('price = 4.10')
    elif lst[i]=='4':
        print('price = 10.20')
    else:
        print('price = 0.00')