Problem Description:

Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?

Input:

The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file. 

Output:

For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should prin 

Sample Input:

6 4

11 8

 Sample Output:

1 2 3 5 6 4

1 2 3 4 5 6 7 9 8 11 10

解题思路:

题目的大致意思就是一个全排列的问题,运用C++里的next_permutation函数就可以解决了,这个函数可以算出数的全排列,需要包含在#include<algorithm>头文件中。

程序代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define N 1001
int main()
{
	int n,m,i,ans;
	int a[N];
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		for(i=0;i<n;i++)
			a[i]=i+1;
		ans=0;
		do
		{
			ans++;
			if(ans==m)
			{
				for(i=0;i<n;i++)
				{
					if(i==n-1)
						printf("%d",a[i]);
					else
						printf("%d ",a[i]);
				}
				printf("\n");
				break;
			}
		}while(next_permutation(a,a+n));
	}
	return 0;
}