Problem Description:

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"? 

Input: 

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

Output:

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

 Sample Input:

5 1 5

3 3 1 2 5

Sample Output: 

解题思路: 

理解好题意,最短路问题,用Dijkstra算法直接AC! 

程序代码: 

#include<iostream>
#include<string.h>
using namespace std;
#define INF 999999
int map[500][500],dist[500],book[500];
int n;
void Dijkstra(int v)
{
    int i,j,min,u;
    memset(book,0,sizeof(book));
    for(i=1;i<=n;i++)
        dist[i]=map[v][i];
    book[v]=1;
    dist[v]=0;
    for(j=1;j<=n-1;j++)
    {
        u=0;
        min=99999999;
        for(i=1;i<=n;i++)
        {
            if(dist[i]<min&&book[i]==0)
            {
                u=i;
                min=dist[i];
            }
        }
        book[u]=1;
        for(i=1;i<=n;i++)
        {
            if(dist[i]>dist[u]+map[u][i])
                dist[i]=dist[u]+map[u][i];
        }
    }
}
int main()
{
    int s,t,i,j,a[500];
    while(cin>>n,n)
    {
        cin>>s>>t;
        memset(map,INF,sizeof(map));
        for(i=1;i<=n;i++)
        {
            cin>>a[i];
            if(i+a[i]<=n)
                map[i][i+a[i]]=1;
            if(i-a[i]>=1)
                map[i][i-a[i]]=1;
        }
        Dijkstra(s);
        if(dist[t]>INF)
            cout<<-1<<endl;
        else
            cout<<dist[t]<<endl;
    }
    return 0;
}