Period


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3315    Accepted Submission(s): 1660


Problem Description


For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.


 



Input


The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.


 



Output


For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.


 



Sample Input


3 aaa 12 aabaabaabaab 0


 



Sample Output


Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4


 


/*
题解:求含有循环结的子串的位置及循环结的循环次数。
最大循环结:cir = len - next[len]  
*/


#include<cstdio>
#include<cstring>
#define N 1000002
int next[N];
void getnext(char *p)
{
int i=0,len=strlen(p);
int j=next[0]=-1;
while(i<len)
{
if(j==-1||p[i]==p[j])
{
i++,j++;
next[i]=j;
}
else j=next[j];
}
}
int main()
{
int n,cas=0;
char p[N];
while(scanf("%d",&n)&&n)
{
scanf("%s",p);
getnext(p);
printf("Test case #%d\n",++cas);
for(int i=0; i<n; i++)
{
int cir=i+1-next[i+1];//最大循环结
//printf("--%d\n",cir);
if(i+1!=cir&&(i+1)%cir==0) printf("%d %d\n",i+1,(i+1)/cir);
}
printf("\n");
}
return 0;
}