Count the string


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5097    Accepted Submission(s): 2396


Problem Description


It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.


 



Input


The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.


 



Output


For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.


 



Sample Input


1 4 abab


 



Sample Output


6


/*
dp[i]=dp[next[i]]+1;
第i个字符结尾的前缀数等于以第next[i]个字符为结尾的前缀数加上它自己本身
*/ 


#include<cstdio>
#include<cstring>
#include<cstring>
#define N 200002
int next[N],dp[N];
char p[N];
void getnext(char *p)
{
int i=0,len=strlen(p);
int j=next[0]=-1;
while(i<len)
{
if(j==-1||p[i]==p[j])
{
i++,j++;
next[i]=j;
}
else
{
j=next[j];
}
}
}
int main()
{
int T,i,j,n,sum;
scanf("%d",&T);
while(T--)
{
memset(dp,0,sizeof(dp));
scanf("%d %s",&n,p);
getnext(p);
for(i=1,sum=0; i<=n; i++)
{
dp[i]=dp[next[i]]+1;
// printf("%d--%d\n",next[i],dp[i]);
sum=(sum+dp[i])%10007;
}
printf("%d\n",sum);
}
return 0;
}