算法训练 删除数组零元素  
时间限制:1.0s   内存限制:512.0MB
    
  从键盘读入n个整数放入数组中,编写函数CompactIntegers,删除数组中所有值为0的元素,其后元素向数组首端移动。注意,CompactIntegers函数需要接受数组及其元素个数作为参数,函数返回值应为删除操作执行后数组的新元素个数。输出删除后数组中元素的个数并依次输出数组元素。  样例输入: (输入格式说明:5为输入数据的个数,3 4 0 0 2 是以空格隔开的5个整数)
  5
  3 4 0 0 2
  样例输出:(输出格式说明:3为非零数据的个数,3 4 2 是以空格隔开的3个非零整数)
  3
  3 4 2
样例输入
7
0 0 7 0 0 9 0
样例输出
2
7 9
样例输入
3
0 0 0
样例输出
0

#include<cstdio>
int b[10010];
int compactIntegers(int *a,int count)
{
int i,j;
for(i=j=0; i<count; i++)
{
if(a[i])
{
b[j++]=a[i];
}
}
return j;
}
int main()
{
int n,t,i,a[10010];
while(scanf("%d",&n)!=EOF)
{
for(i=0; i<n; i++)
{
scanf("%d",&a[i]);
}
t=compactIntegers(a,n);
if(t==0)
{
printf("0\n");
continue;
}
printf("%d\n",t);
printf("%d",b[0]);
for(i=1; i<t; i++)
{
printf(" %d",b[i]);
}
printf("\n");
}
return 0;
}