World Exhibition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2343    Accepted Submission(s): 1123


 

Problem Description

Nowadays, many people want to go to Shanghai to visit the World Exhibition. So there are always a lot of people who are standing along a straight line waiting for entering. Assume that there are N (2 <= N <= 1,000) people numbered 1..N who are standing in the same order as they are numbered. It is possible that two or more person line up at exactly the same location in the condition that those visit it in a group.

There is something interesting. Some like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of X (1 <= X <= 10,000) constraints describes which person like each other and the maximum distance by which they may be separated; a subsequent list of Y constraints (1 <= Y <= 10,000) tells which person dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between person 1 and person N that satisfies the distance constraints.

 

 

Input

First line: An integer T represents the case of test.

The next line: Three space-separated integers: N, X, and Y. 

The next X lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= N. Person A and B must be at most C (1 <= C <= 1,000,000) apart.

The next Y lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= C. Person A and B must be at least C (1 <= C <= 1,000,000) apart.

 

 

Output

For each line: A single integer. If no line-up is possible, output -1. If person 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between person 1 and N.

 

 

Sample Input


 


1 4 2 1 1 3 8 2 4 15 2 3 4

 

 

Sample Output


 


19

 

 

Author

alpc20

 

 

Source

​2010 ACM-ICPC Multi-University Training Contest(15)——Host by NUDT​

 

 

Recommend

zhouzeyong

 

题意:

n个人站成一行,有两个人之间的距离最少是多少,有两个人之间的距离最大是多少,问第一个人到第 n个人之间的距离最大是多少?

分析:

简单差分约束

建边有三条:S[i] 表示第i个人与第一个人距离。

1,S[b] - S[a] <= c

2,S[b] - S[a] >= c

 

#include<cstdio>
#include<cstring>
#include<queue>
#include<iostream>
using namespace std;
const int N = 1000000 + 5;
int head[N],tot,cnt[N],dis[N],list[N];
bool vis[N];
int n,m;
struct node{
int next,to,v;
}e[N];
void adde( int a, int b, int c ){
e[++tot].next = head[a];
head[a] = tot;
e[tot].to = b;
e[tot].v = c;
}
bool spfa(int be){

memset(vis,false,sizeof(vis));
for( int i = 0; i <= n; i++ )
dis[i]=1e9;
memset(cnt,0,sizeof(cnt));

queue<int>q;
q.push(be);
cnt[be]++;
vis[be] = true;
dis[be] = 0;
while( !q.empty() ){
int u = q.front();
q.pop();
vis[u] = false;
for( int i = head[u]; i; i = e[i].next){
int v = e[i].to;
if( dis[v] > dis[u] + e[i].v ) {
dis[v] = dis[u] + e[i].v;
if( !vis[v] ) {
vis[v] = true;
if( ++cnt[v]>n ) return false;
q.push(v);
}
}
}
}
return true;
}
int main(){
int a ,b ,c;
int T;
scanf("%d",&T);
int m1,m2;
while(T--){
scanf("%d %d %d" ,&n ,&m1,&m2);
memset(head ,0 ,sizeof(head));
tot = 1;
int a,b,c;
while(m1--)
{
scanf("%d%d%d",&a,&b,&c);
adde(a,b,c);
}
while(m2--)
{
scanf("%d%d%d",&a,&b,&c);
adde(b,a,-c);
}

if(spfa(1)==0) printf("-1\n");
else if(dis[n]==1e9)
printf("-2\n");
else
printf("%d\n",dis[n]);
}
return 0;
}