Atlantis

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19655    Accepted Submission(s): 7893


 

Problem Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

 

Input

The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.

 

Output

For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.

 

Sample Input

2 10 10 20 20 15 15 25 25.5 0

 

Sample Output

Test case #1 Total explored area: 180.00

 

Source

​​Mid-Central European Regional Contest 2000 ​​

 

Recommend

linle   |   We have carefully selected several similar problems for you:  ​​1828​​ ​​1255​​ ​​1698​​ ​​1540​​ ​​1754​​ 

 

​Statistic​​​ | ​​Submit​​ | ​​Discuss​​ | ​​Note​​


线段树扫描线入门题,具体了解 ​​点这里​​

 

#include<bits/stdc++.h>
using namespace std;
const int MAXN=2222;
#define lson i<<1,l,m
#define rson i<<1|1,m+1,r
#define root 1,1,k-1
double X[MAXN];
struct node
{
double l,r,h;
int d; ///d为1或-1,标记扫描线是矩形的上位还是下位边.
node(){}
node(double a,double b,double c,int d): l(a),r(b),h(c),d(d){}
bool operator <(const node &b)const
{
return h<b.h;
}
}nodes[MAXN];
///cnt: >=0时表示本节点控制的区域内下位边个数-上位边个数的结果.
///如果==-1时,表示本节点左右子树的上下位边数不一致.
///sum: 本节点控制的区域内cnt值不为0的区域总长度.
int cnt[MAXN*4];
double sum[MAXN*4];
///如果cnt!=-1,那么下放cnt信息,并更新子节点的sum信息.
void PushDown(int i,int l,int r)
{
int m=(l+r)>>1;
if(cnt[i]!=-1)
{
cnt[i<<1]=cnt[i<<1|1]=cnt[i];
sum[i<<1]= (cnt[i]?(X[m+1]-X[l]):0) ;
sum[i<<1|1]= (cnt[i]?(X[r+1]-X[m+1]):0) ;
}
}
///根据子节点的cnt值和sum值更新父节点的cnt和sum值
void PushUp(int i,int l,int r)
{
if(cnt[i<<1]==-1 || cnt[i<<1|1]==-1)
cnt[i]=-1;
else if(cnt[i<<1] != cnt[i<<1|1])
cnt[i]=-1;
else
cnt[i]=cnt[i<<1];
sum[i]=sum[i<<1]+sum[i<<1|1];
}

void update(int ql,int qr,int v,int i,int l,int r)
{
if(ql<=l && r<=qr)
{
if(cnt[i]!=-1)
{
cnt[i]+=v;
sum[i] = (cnt[i]? (X[r+1]-X[l]):0);
return ;
}
}
PushDown(i,l,r);
int m=(l+r)>>1;
if(ql<=m) update(ql,qr,v,lson);
if(m<qr) update(ql,qr,v,rson);
PushUp(i,l,r);
}
///二分寻找区间
int bin(double key,int n,double d[])
{
int l=1,r=n;
while(r>=l)
{
int m=(r+l)>>1;
if(d[m]==key)
return m;
else if(d[m]>key)
r=m-1;
else
l=m+1;
}
return -1;
}
int main()
{
int q;
int kase=0;
while(scanf("%d",&q)==1&&q)
{
int n=0,m=0;
for(int i=1;i<=q;i++)
{
double x1,y1,x2,y2;
scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
X[++n]=x1;
nodes[++m]=node(x1,x2,y1,1);
X[++n]=x2;
nodes[++m]=node(x1,x2,y2,-1);
}
sort(X+1,X+n+1);
sort(nodes+1,nodes+m+1);
int k=unique(X+1,X+n+1)-(X+1);//去掉相邻的重复元素
//build(1,1,k-1);
memset(sum,0,sizeof(sum));
memset(cnt,0,sizeof(cnt));
double ret=0.0;//最终面积
for(int i=1;i<m;i++)
{
int l=bin(nodes[i].l,k,X);
int r=bin(nodes[i].r,k,X)-1;///左开右闭的性质
//cout<<l<<" "<<r<<endl;
if(l<=r) update(l,r,nodes[i].d,root);
ret += sum[1]*(nodes[i+1].h-nodes[i].h);
}
printf("Test case #%d\nTotal explored area: %.2lf\n\n",++kase,ret );
}
}