Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes tiseconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input
There are multiple test cases. 
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers t i(1 ≤ t i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output
Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input
1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output
2
4
5
 

题意:塔有m滴血,有n种船可以选择,每种船建造时间为t,建好后每秒对敌方造成l点伤害,问最少多少时间能干掉对方
分析:

定义dp[j]表示在j这个时间,所造成的最大伤害。

然后我们枚举时间,在每个特定的时间内,枚举船的种类,找到最大值

动态转移方程: dp[j+t[i]] = max(dp[j+t[i]],dp[j]+j*l[i]);

解释:我们要求j+t[i]这段时间,我们先假设他它在就来建设完成,需要t[i]时间,然后j这个时间它会一直工作,造成的伤害为j*l[i]

#include<cstdio>
#include<iostream>
#include<fstream>
#include<algorithm>
#include<functional>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<numeric>
#include<cctype>
#include<cmath>
#include<ctime>
#include<queue>
#include<stack>
#include<list>
#include<set>
#include<map>
using namespace std;
using namespace std;
int dp[10000],t[100],l[100];

int main()
{
int n,m,ans;
while(~scanf("%d%d",&n,&m))
{
for(int i = 0; i<n; i++)
scanf("%d%d",&t[i],&l[i]);
memset(dp,0,sizeof(dp));

for(int j = 0; j<350; j++)
{
for(int i = 0; i<n; i++)
{
dp[j+t[i]] = max(dp[j+t[i]],dp[j]+j*l[i]);
}
}
ans = (1<<30);
for(int i = 0; i<350; i++)
{
if(dp[i]>=m)
{
ans=min(ans,i);
}
}
printf("%d\n",ans);
}

return 0;
}