B-number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3376 Accepted Submission(s): 1891


 

Problem Description

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

 

Input

Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

 

Output

Print each answer in a single line.

 

Sample Input

13 100 200 1000

 

Sample Output

1 1 2 2

 

Author

wqb0039

 

Source

​2010 Asia Regional Chengdu Site —— Online Contest ​

 

题意:找出1~n有多少个数既含有13又能被13整除。

分析:数位DP模板题,记忆化搜索配合数位dp求解。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
typedef long long ll;
int a[20];
ll dp[25][3][13];
//dp[i][mod][j]:长度为i,余数为mod,状态为j,

ll dfs(int pos,int mod,int sta,bool limit)
//sta==0,高位没有13
//sta==1,高位没有13 但末尾1
//sta==2,高位有13
{
if(pos==-1) return (mod==0)&&(sta==2);
if(!limit && dp[pos][sta][mod]!=-1) return dp[pos][sta][mod];
int up=limit ? a[pos] : 9;
ll tmp=0;
for(int i=0;i<=up;i++)
{
int tmod = (mod*10+i)%13;
int tsta=sta; //很巧妙的一步
if(sta==0&&i==1)//高位没有13,末尾不是1,现在添1
tsta=1;
else if(sta==1&&i!=1&&i!=3)//高位没有13,末尾是1,但添加不是3也不是1,返回sta=0状态
tsta=0;
else if(sta==1&&i==3)//高位不含13,且末尾是1,末尾添加3返回2的状态
tsta=2;
tmp+=dfs(pos-1,tmod,tsta,limit && i==a[pos]);
}
if(!limit) dp[pos][sta][mod]=tmp;
return tmp;
}
ll solve(int x)
{
int pos=0;
while(x)
{
a[pos++]=x%10;
x/=10;
}

return dfs(pos-1,0,0,true);
}
int main()
{
ll n;
//memset(dp,-1,sizeof dp);可优化
while(~scanf("%lld",&n))
{
memset(dp,-1,sizeof dp);
printf("%lld\n",solve(n));
}
return 0;
}