Check Corners

Time Limit: 2000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3599    Accepted Submission(s): 1290


 

Problem Description

Paul draw a big m*n matrix A last month, whose entries Ai,j are all integer numbers ( 1 <= i <= m, 1 <= j <= n ). Now he selects some sub-matrices, hoping to find the maximum number. Then he finds that there may be more than one maximum number, he also wants to know the number of them. But soon he find that it is too complex, so he changes his mind, he just want to know whether there is a maximum at the four corners of the sub-matrix, he calls this “Check corners”. It’s a boring job when selecting too many sub-matrices, so he asks you for help. (For the “Check corners” part: If the sub-matrix has only one row or column just check the two endpoints. If the sub-matrix has only one entry just output “yes”.)

 

 

Input

There are multiple test cases. 

For each test case, the first line contains two integers m, n (1 <= m, n <= 300), which is the size of the row and column of the matrix, respectively. The next m lines with n integers each gives the elements of the matrix which fit in non-negative 32-bit integer. 

The next line contains a single integer Q (1 <= Q <= 1,000,000), the number of queries. The next Q lines give one query on each line, with four integers r1, c1, r2, c2 (1 <= r1 <= r2 <= m, 1 <= c1 <= c2 <= n), which are the indices of the upper-left corner and lower-right corner of the sub-matrix in question. 

 

 

Output

For each test case, print Q lines with two numbers on each line, the required maximum integer and the result of the “Check corners” using “yes” or “no”. Separate the two parts with a single space.

 

 

Sample Input

4 4 4 4 10 7 2 13 9 11 5 7 8 20 13 20 8 2 4 1 1 4 4 1 1 3 3 1 3 3 4 1 1 1 1

 

 

Sample Output

20 no 13 no 20 yes 4 yes

 

 

Source

​2009 Multi-University Training Contest 9 - Host by HIT​

 

 

Recommend

gaojie

 

题意:

给一个矩阵,然后给Q个询问,每个询问有四个数,分别代表询问的子矩阵的左上角和右下角,然后找出子矩阵的最大值输出,然后再把这个值与

子矩阵的四个角的值比较,如果有至少一个等于这个最大值就输出“yes”,否则输出“no”

分析:

二维线段树的裸题

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
const int INF = 0x3f3f3f3f;
const int MAXN = 500;
struct Nodey
{
int l,r;
int Max,Min;
};
int locy[MAXN],locx[MAXN];
struct Nodex
{
int l,r;
Nodey sty[MAXN*4];
void build(int i,int L,int R)
{
sty[i].l = L;
sty[i].r = R;
sty[i].Max = -INF;
sty[i].Min = INF;
if(L == R)
{
locy[L] = i;
return;
}
int mid = (L + R)>>1;
build(i<<1,L,mid);
build((i<<1)|1,mid+1,R);
}
int queryMin(int i,int L,int R)
{
if(sty[i].l == L && sty[i].r == R)
return sty[i].Min;
int mid = (sty[i].l + sty[i].r)>>1;
if(R <= mid)return queryMin(i<<1,L,R);
else if(L > mid)return queryMin((i<<1)|1,L,R);
else return min(queryMin(i<<1,L,mid),queryMin((i<<1)|1,mid+1,R));
}
int queryMax(int i,int L,int R)
{
if(sty[i].l == L && sty[i].r == R)
return sty[i].Max;
int mid = (sty[i].l + sty[i].r)>>1;
if(R <= mid)return queryMax(i<<1,L,R);
else if(L > mid)return queryMax((i<<1)|1,L,R);
else return max(queryMax(i<<1,L,mid),queryMax((i<<1)|1,mid+1,R));
}
}stx[MAXN*4];
int n;
void build(int i,int l,int r)
{
stx[i].l = l;
stx[i].r = r;
stx[i].build(1,1,n);
if(l == r)
{
locx[l] = i;
return;
}
int mid = (l+r)>>1;
build(i<<1,l,mid);
build((i<<1)|1,mid+1,r);
}
//修改值
void Modify(int x,int y,int val)
{
int tx = locx[x];
int ty = locy[y];
stx[tx].sty[ty].Min = stx[tx].sty[ty].Max = val;
for(int i = tx;i;i >>= 1)
for(int j = ty;j;j >>= 1)
{
if(i == tx && j == ty)continue;
if(j == ty)
{
stx[i].sty[j].Min = min(stx[i<<1].sty[j].Min,stx[(i<<1)|1].sty[j].Min);
stx[i].sty[j].Max = max(stx[i<<1].sty[j].Max,stx[(i<<1)|1].sty[j].Max);
}
else
{
stx[i].sty[j].Min = min(stx[i].sty[j<<1].Min,stx[i].sty[(j<<1)|1].Min);
stx[i].sty[j].Max = max(stx[i].sty[j<<1].Max,stx[i].sty[(j<<1)|1].Max);
}
}
}
int queryMax(int i,int x1,int x2,int y1,int y2)
{
if(stx[i].l == x1 && stx[i].r == x2)
return stx[i].queryMax(1,y1,y2);
int mid = (stx[i].l + stx[i].r)>>1;
if(x2 <= mid)return queryMax(i<<1,x1,x2,y1,y2);
else if(x1 > mid)return queryMax((i<<1)|1,x1,x2,y1,y2);
else return max(queryMax(i<<1,x1,mid,y1,y2),queryMax((i<<1)|1,mid+1,x2,y1,y2));
}

int a[MAXN][MAXN];
int main()
{
int nn, mm;
while (~scanf("%d%d",&nn, &mm)) {
int fn = nn, fm = mm;
n = max(nn, mm);
build(1,1,n);
for(int i = 1;i <= n;i++)
for(int j = 1;j <= n;j++)
{
int b;
if (i <= fn && j <= fm)
{
scanf("%d", &b);
Modify(i, j, b);
a[i][j] = b;
}
else
Modify(i, j, 0);
}
int q;
scanf("%d",&q);
while(q--)
{
int x1, y1, x2, y2;
scanf("%d%d%d%d",&x1,&y1,&x2, &y2);
int maxx = queryMax(1, x1, x2, y1, y2);
int flag = 0;
if (a[x1][y1] == maxx)
flag = 1;
else if (a[x2][y1] == maxx)
flag = 1;
else if (a[x1][y2] == maxx)
flag = 1;
else if (a[x2][y2] == maxx)
flag = 1;
if (flag == 1)
printf("%d yes\n", maxx);
else
printf("%d no\n", maxx);
}
}
return 0;
}