Prime Path

Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 27754

 

Accepted: 15152

Description

POJ 3126 Prime Path  素数+BFS_git

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 

— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 

— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 

— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 

— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 

— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 

— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 


Now, the minister of finance, who had been eavesdropping, intervened. 

— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 

— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 

— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 

1033
1733
3733
3739
3779
8779
8179

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

Source

​Northwestern Europe 2006​

算法分析:

题意:

给你两个四位数你n,m,改变n四位数字,一次只能变化一个,问变成m需要几步,中间必须要满足都是素数

实现

以为是最短路,竟然忘了BFS,哎,实现看看代码把,很简单(没看到是四位数)。

代码实现:

#include<cstdio>  
#include<cstring>
#include<cstdlib>
#include<cctype>
#include<cmath>
#include<iostream>
#include<sstream>
#include<iterator>
#include<algorithm>
#include<string>
#include<vector>
#include<set>
#include<map>
#include<stack>
#include<deque>
#include<queue>
#include<list>
using namespace std;
typedef long long ll;
int n,m;
int listt[11000];
queue<int> q;
int isPrime(int n)
{ //返回1表示判断为质数,0为非质数,在此没有进行输入异常检测
float n_sqrt;
if(n==2 || n==3) return 1;
if(n%6!=1 && n%6!=5) return 0;
n_sqrt=floor(sqrt((float)n));
for(int i=5;i<=n_sqrt;i+=6)
{
if(n%(i)==0 | n%(i+2)==0) return 0;
}
return 1;
}
int solve(int x)
{
//cout<<x<<endl;
if(isPrime(x)==1&&x!=n&&listt[x]==-1)
{
q.push(x);
listt[x]=listt[n]+1;
}
return 1;
}
int main()
{
int T;
cin>>T;
while(T--)
{

scanf("%d%d",&n,&m);
while(!q.empty()) q.pop();
q.push(n);
memset(listt,-1,sizeof(listt));
listt[n]=0;
while(!q.empty()&&n>1)
{
n=q.front();
q.pop();
int a1=n%10;
int a2=(n/10)%10;
int a3=(n/100)%10;
int a4=n/1000;

for(int i=1;i<10;i++) //变换第一位,首位不能是0
solve(n-a4*1000+i*1000);
for(int i=0;i<10;i++) //变化第二,三,四位
{
solve(n-a3*100+i*100);
solve(n-a2*10+i*10);
solve(n-a1+i);
}
}
cout<<listt[m]<<endl;
}
return 0;
}