ProblemD

Time Limit : 2000/1000ms(Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 1   AcceptedSubmission(s) : 1

ProblemDescription

A number whose only prime factors are 2,3,5or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12,14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.<br><br>Write a program to find and print the nth element in thissequence<br>

 

 

Input

The input consists of one or more testcases. Each test case consists of one integer n with 1 <= n <= 5842.Input is terminated by a value of zero (0) for n.<br>

 

 

Output

For each test case, print one line saying"The nth humble number is number.". Depending on the value of n, thecorrect suffix "st", "nd", "rd", or"th" for the ordinal number nth has to be used like it is shown inthe sample output.<br>

 

 

Sample Input

1

2

3

4

11

12

13

21

22

23

100

1000

5842

0

 

 

Sample Output

The 1st humble number is 1.

The 2nd humble number is 2.

The 3rd humble number is 3.

The 4th humble number is 4.

The 11th humble number is 12.

The 12th humble number is 14.

The 13th humble number is 15.

The 21st humble number is 28.

The 22nd humble number is 30.

The 23rd humble number is 32.

The 100th humble number is 450.

The 1000th humble number is 385875.

The 5842nd humble number is 2000000000.

 

 

算法分析:

humble number 是满足是23 5 7的倍数,然后你输出第n个数。

关键就是如何把humble number从小到大放到f中,可以从一开始算起,一个个求出来。

f[i]表示第i个小的数

状态转移方程:f[i]=min(f[two]*2,min(f[there]*3,min(f[five]*5,f[seven]*7)))

那个st,nd真不知道是啥,原来在yingyu里

除了11,12,13例外,其余格式余数1为st,2为nd,3为rd,其余为th。

代码实现:

#include<bits/stdc++.h>
using namespace std;
#define maxx 5842
int main()
{
int n,i,j;
int f[maxx+1],two=1,there=1,five=1,seven=1;
memset(f,0,sizeof(f));//清0
f[1]=1;//1特殊
for(i=2;i<=5842;i++)//开始枚举
{
f[i]=min(f[two]*2,min(f[there]*3,min(f[five]*5,f[seven]*7)));
if(f[i]==f[two]*2)two++;
if(f[i]==f[there]*3)there++;
if(f[i]==f[five]*5)five++;
if(f[i]==f[seven]*7)seven++;
}
while(~scanf("%d",&n)&&n)
{
if(n%10==1&&n%100!=11)
{printf("The %dst humble number is %d.",n,f[n]);}
else if(n%10==2&&n%100!=12)
{printf("The %dnd humble number is %d.",n,f[n]);}
else if(n%10==3&&n%100!=13)
{ printf("The %drd humble number is %d.",n,f[n]);}
else printf("The %dth humble number is %d.",n,f[n]);
printf("\n");
}
return 0;
}